Roblox Flashing White Randomly, Causing Eye Strain

Unfortunately, the website is now broken too, causing it to not launch experiences on some devices, can’t win-

this happens to me when i stream on discord web, when i stream on the app it works fine

From all that I know, this issue is fixed. I have not had it happen at all as of recently

Still not fixed for me. I had this problem before, it stopped, but it keeps happening again.

Not fixed for me either, stopped for a while like Blou said, but recently when sharing my screen I still got greeted by a cute epilepsy concert. The people on discord don’t seem to be able to see it however.

1 Like

Oh, also I found out that if you’re streaming and you lag switch your screen goes white.

2 Likes

I removed the solution as it seems that others are still having the issue. I’ll keep it up for people who are suffering from this.

I hope these issues do get resolved for everyone!

Sorry for the bump, but I think this might also help some people with this issue. I haven’t experienced this issue since I fixed mine.

I completely forgot about this post, but my friends have tried toggling this, and they also followed the previous advice I gave to them, and it didn’t fix their issues.

Not entirely sure if only Windows 11 has this toggle, but it’s worth checking on:

image
image

Switch this toggle on. It apparently fixed the flashing for my friends who had this issue, and we literally tried everything before finding this.

image

If you want, you could also toggle the option above that one for accelerated gpu scheduling. It’s an added performance benefit, so I recommend it.


If the toggle is already on, try switching it off and see if that fixes it for you. I don’t fully remember if on is what fixes it or not, but I’m pretty sure it is :+1:

2 Likes

This issue is still going on, is there any update on this??? It’s extremely dangerous for some players.

External Media

Hey i’ve Managed To Find a way to “fix” it in a way because i Also had this issue
you need to use BloxStrap (it Modifies the client the way you want)

The issue is on DirectX Graphics Api so i’ve Switched the API to vulkan and it worked
now you may ask how did i change the API?

in Bloxstrap i went to “FastFlag Editor” where you can manually change things and there you can Add new fast flags or Import JSON
Here is JSON for that

{“FFlagDebugGraphicsPreferVulkan”:“true”,“FFlagDebugGraphicsDisableDirect3D11”:“true”}
Alternatively you can press ALT+Enter when using bloxstrap which does something to full screen optimizations that fix it

Hope this Helps (if you can share it to as many people with this issue as possible) : D

1 Like