Roblox Game Client is not loading in VR - Oculus Quest 2

I understand that Roblox VR is not a priority so understand if this report is discarded, however I cannot seem to find any other record of this issue online.

  • I am trying to use Roblox on the Oculus Quest 2 via Oculus Link for the first time on a brand new headset.
  • Whenever I open a Roblox game, “Roblox Game Client” begins to load however that screen never changes and it just loads indefinitely until I close it.
  • The Roblox client on my PC does load and there no option to enable VR in the Roblox settings menu.

If there are any sort of log files I can provide, I am more than happy to.

Specs: AMD Ryzen 7 4800HS, 16GB, NVIDIA GeForce RTX 2060

The screen it stays on:

Extra info:

  • Oculus link has “Unknown Sources” ticked
  • I have tried Steam VR which works through oculus link, but if I load the Roblox client, link will close Steam VR and Roblox Client loading will take over.
16 Likes

Never had this issue with my Rift S, could be an Oculus issue. You could try contacting Oculus Support?

5 Likes

If trying to run Roblox through Steam or Virtural Desktop to get it onto a Quest 2 headset, you’ll need to make sure Steam VR is running with the menu in the bottom center of the screen.

5 Likes

I have got Steam VR running on my PC + headset. Only issue is that Steam VR is running via Oculus Link.

Meaning that when I join a Roblox game, Oculus link notices and closes the Steam VR view on the headset so it can try and run the Roblox Client instead (via Oculus Link, not Steam VR)

3 Likes

From what I am hearing, you can’t run Roblox in VR. Same happened to me, ensure that you have restarted your computer, or reinstalled Roblox while your VR headset is plugged in, that’s what I did. It worked!

Ensure your Oculus Quest is up-to-date… but I am not sure if Oculus Quest 2 is supported yet.

Do other VR apps work on your headset? If not contact Oculus support.

I’m working on a Roblox launcher, futuristic looking, your placed in a room and can launch Roblox games from there. Development should take 5 more months if you want it. Don’t think I will be able to distribute this via Steam or Oculus store, so I’ll direct message you the app when it’s done. But, this is a worst-case scenario, and I am pretty sure Roblox would come up with this faster then me. :sweat:

7 Likes

Other VR apps work, including demos that came with the Oculus software. Definitely seems to be an issue with my version of the Roblox software itself. I have tried restarting and re-installing Roblox but unfortunately had no luck. Studio is not working either, however the headset does recognise it and tries to load it - just never actually does.

All the YouTube tutorials on doing it make it out to be a very simple process so it’s very frustrating having this seemingly unique bug.

Love the idea of the launcher and look forward to seeing it.

3 Likes

Try reinstalling the client. Does Studio launch in VR?

For all I know, the Quest 2 is supported, as I have one as well, and it has worked with Oculus Link.

If you are using Oculus Link (or just wired to your pc), make sure the cord you are using is USB 3.0 or higher (i recommend this one)

4 Likes

Unfortunately no re-install has worked so far. Studio doesn’t launch either. The cable I am using is a 2.0 USB C to USB C however as other games and oculus link are working - I assume this is not a problem?

image

I think this is most likely an issue with my laptop / Roblox itself so might try on another Windows device when I can.

3 Likes

No. This could be the problem because some games on the Oculus and Steam VR store are optimized enough to work with 2.0, while since Roblox is an Unknown Source, it required 3.0.

Make sure you are also plugging the cord in to a proper 3.0 slot. Usually the the USB Classic and Type-C will have some sort of blue coloured marker on it (USB classic is the plastic connector inside of the shell, Type-C is a blue ring around the edge) but sometimes computers dont have this. So instead, look out for this symbol (see photos below):

The two “SS” means SuperSpeed, which is a fancy term for 3.0.

(The lightning bolt on the first photo does not apply to this. That basically means that power will be supplied to the connecting device even when the computer is off. I use this to charge my phone because i leave my laptop plugged in.)

This is what a USB 3.0-3.2 port would look like (on newer computers)

Its late here and im gonna get off my pc to chill. I can try to help you out tomorrow afternoon if you still need it :slight_smile:

3 Likes

Alright, I have acquired a USB 3.2 cable and plugged into an SS port (thanks for the direction) on my laptop. Tried playing a Roblox game again with the following workflow unfortunately to no avail.

  • Load Oculus software
  • Plug in headset to SS port and enable link
  • After link loaded, pressed play on VR compatible Roblox game on PC
  • Again, “Roblox Game Client Loading” stuck on screen.

I also tried re-installing the Roblox client (while keeping studio installed) and keeping link open on the headset however I still had the stuck loading screen, just without the logo or title this time.

(Thanks for the help so far, really appreciate it and would love to get this working)

3 Likes

woah. never seen that before…

Have you tried restarting your laptop afterward? It looks like OL couldn’t get the image and title data. This could also happen because the cord was plugged in while the headset was on or OL was open.

Im not too sure how to fix this any farther. If I think of something, ill let you know.

no problem :blush:

anyways, I am going to get off for the night. Again, ill let you know if I figure something out. Have a nice evening :happy3:

2 Likes

I’ll try to do more research, I can log into VR tomorrow to see if it’s a global problem… or something.

1 Like

Hello. I’m afraid that this issue is due to there not being support for the Oculus Quest 2 VR headset. Currently supported VR headsets are the Oculus Rift and HTC Vive.

6 Likes

The oculus quest 2 is recognized as a rift with oculus link

If you’d like a workaround for this, I play on Quest 2 in VR fine. Use virtual desktop with SteamVR, and it works, besides a few controls not working correctly.

I play ROBLOX on a og quest with link with usb 2.0 and it works fine

Is #roblox up to date (newest version), or is everything pluged in? This might be a problem with your VR headset.

Quick update: It worked immediately on my old laptop - same cable. So it’s either an issue with the ports on my new laptop or the Roblox / link software itself.

You don’t know how oculus link works it makes your quest or quest 2 function like a rift s when you plug it in to a pc

1 Like

did anyone ever solve this, because the same error is happening to me

4 Likes