Roblox Game Client/Player Not Responding

Anytime I try to play Roblox through the website, the moment the player opens, it stops responding.

I’m on a laptop I got a few days ago. Runs on Windows 11 and I use Opera GX for my browser. It came with Norton 360, NVidia, and MSI Center software, in case any of those are somehow the issue.

I started by trying to reinstall Roblox, clear its cache, system restarting, and optimization settings, none of it worked.

I tried playing it on my old laptop, which also uses Windows 11 and Opera GX, and is on the exact same internet connection, and it worked fine. It did not come with the software mentioned above.

I then decided to go to Roblox support and did a clean boot of my system, neither of which helped.

After all of that, I decided to bite the bullet and try a full factory reset, and still nothing.

The windows app works fine for some reason, but I’d seriously prefer getting the player up and working again, and I’m pretty desperate for help.


This may not help much, but I did several reinstalls by deleting the files in appdata (appdata/local/Roblox) and then uninstalled the application shortcuts to be sure and then it just fixed itself somehow after I gave up on trying. In the logs, I was getting HTTP errors and authentication errors so I asked Roblox about it, and didn’t really get anywhere before it started working on its own. I also logged out of Roblox a few times just to see if it would help. I’m not sure if any of that would be useful in this case as I’m not sure if you are having the same errors, but if you haven’t tried that maybe it’ll work. Just a thought.

I originally thought that my problem was related to RAM or graphics drivers as something similar has happened before, but that didn’t help after updating them.

Also, try and set the Roblox player application to run as Administrator. You can do that by right clicking Roblox from the Windows search bar, select open file location, then right click the Roblox Player and select properties then compatibility and select run as administrator and press apply.

Doesn’t seem to be working but thanks for the help anyway

Update: It stopped working again, so I was able to narrow it down to my Logitech steering wheel. If the wheel is plugged in, Roblox would stop responding when I’d open it. I closed it, unplugged the wheel, and then opened it again and it worked fine. To confirm that was the issue, I closed it, plugged the wheel in, and opened Roblox and it stopped working. If you don’t have a wheel, maybe it’s another USB device or controller that can be used with Roblox that is interfering with the startup.

1 Like

That doesn’t seem like it was the problem either. The only things i have connected are a hard drive, my headphones, and my mouse. I tried unplugging them just in case but no luck unfortunately.

Hmmm weird, try to temporarily turn off Norton to see if that works. I wouldn’t say this is a hardware issue as this is a new computer. Are the graphics drivers updated through Nvidia?

I already uninstalled norton since it was only a 60 day free trial and I didnt feel like i needed it.

I did a clean install of the nvidia drivers just to make sure and that didn’t fix the problem either.

So after some experimenting I’ve made some discoveries.

I tried uninstalling all Nvidia related software on my computer which stopped the problem of the website version of Roblox immediately freezing, even causing audio to start going through, but it would get stuck on a white screen. On top of that, the app would check for updates upon being opened and then also get stuck on a white screen.

1 Like

I’ve narrowed this change down to the disabling/uninstalling of the Nvidia display adapter, so now I just need to figure out if there’s any way to fix it either with or without the adapter


hello, im having the same problem and stumbled upon this. did you end up fixing it? I read you have an MSI too, like me, so i think it has to do with that. any idea?

1 Like

If I had fixed it I would’ve posted the solution.
I’ve just been dealing with it and using the store app for the time being.
As I said before I think it has to do with the Nvidia software on my MSI laptop, I don’t think any of the MSI stuff itself is the issue.


So thanks to the help of fixie they have discovered that if you go to System > Display > Graphics > Default graphics settings on a Windows system in the settings and enable Optimizations for windowed games, Roblox will start opening as a background process, which does not solve the issue yet but it is a problem there is much more information on.


After all this time, it roblox suddenly started worked with the optimizations setting mentioned above enabled. This is sadly the only solution I have.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.