Roblox games load for about 3 seconds then instantly crash

It saddens me that we’ve gotten to the point of debugging this ourselves. No news from ROBLOX for more than a week.
Thank you for drawing my attention to this tool!


If they continue to ignore us. Ill just contact my state’s attorney general on behalf of everyone that has spent money that’s now unusable


Object code can’t really be read anywhere. Only the CPU understands the language in your dump file.

I already got moderated

They removed the post and its not only the one post they removed from this account.
Hopefully they didnt instantly perm ban my account so getting these posts just removed is alot better than getting perm banned on roblox

Have you tried this solution? It worked for me although it still crashed or closed itself when I joined two or three games but then it worked again

This Didnt work for me, unfortunately

1 Like

I’ve tried many things to fix this problem, and absolutely nothing works. I guess i will continue using the desktop app :confused:

1 Like

Hi, everyone,
I would like to share my experience with Roblox crashing; for the past ~2 weeks I have been crashing consistently after ~7 minutes of play time, today I fixed my problem.

The issue:

By default, I was playing Roblox through the directory C:\Users\<username>\AppData\Local\Roblox\Versions\version-<VersionNumber>\RobloxPlayerBeta.exe, which I assume is the new 64-bit version.
For some reason, I would crash after ~7 of having Roblox open consistently.

The solution:

By manually going to the directory C:\Program Files (x86)\Roblox\Versions\version-<VersionNumber> and starting RobloxPlayerBeta.exe through there, I was able to play Roblox without crashing.
Around the time I expected to crash, I instead received a memory dump notification. Something to note is if I don’t press ‘OK’ for the memory dump quick enough, I will crash.

The notification:
^^Full screenshot^^

What I get when I press ‘OK’:

What I think the problem is:

Obviously, I think that whatever that ‘memory dump’ notification is, the 64-bit client does not like it and instead chooses to crash.

I hope my information has been invaluable to someone.
Also, please start compressing images using WebP instead of JPEG 1, and allow DevForum users to upload WebP images.
- Knew


Unfortunately, that solution didn’t work for me.


That’s unfortunate to hear. I don’t understand how such a problem can happen for so long, it definitely seems memory related (on Roblox’s end, I have 32GB@3200MHz).

EDIT: I should also mention that you NEED to press that ‘OK’ button, you have like 5 seconds to do it before it crashes. After that, you are golden. It isn’t a fix, but a workaround for the time being.

On the Roblox down outage site, over 800 reports in the past hour alone.

Why is this still happening after 3 weeks??


For me, Roblox didn’t even show up.
So maybe with the update the way cache is read and wrote, and the code changed too much so it couldn’t update properly, and when it tries to read the code/cache but it doesn’t understand it, it freaks out and crashes?
For me it didn’t run at all but when I uninstalled roblox and manually removed everything, and reinstalled it, it was able to even show up for 3 seconds.
So I removed cache (using the “Clean Disk” feature of Windows, and include DirectX cache) and now it does the same thing as niyuuesuto.


I have sad news, unfortunately the solution is incredibly hit or miss. Sometimes, if I press ‘OK’ quick enough, I can stay without crashing but sometimes it just crashes after giving me the memory dump notification. :confused:
At least I still have a chance to play Roblox, unlike before.

1 Like

Hello everyone, I believe I discovered a fix to most issues. This is how I fixed mine: open file explorer, open properties (or the 3 dots on the top), click clean up, allow it to do its scan, when it shows all the things you can delete be sure thumbnails is one of the things you can delete. All other clean up files are optional. I hope everyone can return to normally playing roblox, thanks.

Loaded and ran just fine for me …

That was 25 days ago, it loaded fine the next day for me lol.

1 Like

I haven’t been able to play any games for several weeks. The client keeps crashing every time I open it, no matter how many times I restart my computer, reinstall the client, or do a disk cleanup. I have no idea what to try at this point.


Same for me. I have been using the desktop app so I can play roblox, but it has some weird bugs and glitches that make me hate using it. Recently, the client has been more stable, though I can only play royale high, which sometimes crashes after joining, but I’ve been able to join without crashing

I’d wish roblox had fixed this big issue already. It’s so annoying to have no news about this glitch or roblox’s awareness about the same issue that has been affecting a lot of people