Roblox games load for about 3 seconds then instantly crash

When I try to launch into a Roblox game it loads in for about 1-3 seconds before it closes itself, no crash warning, it doesn’t freeze with the loading symbol or faded white it just closes itself.

This started with the new Byfron Update I’m guessing, my Roblox updated when I tried launching into a game and it updated to it.

This has only started happening to me today and I even reinstalled Roblox and it still won’t work.

My System Specs

Acer Aspire
intel core i7-720QM processor
NVIDIA GeForce GT 420M
4GB DDR3 Memory

There are no screenshots or anything because it doesn’t have any error messages or crash notifications, also it occurs in every game I’ve tried to launch.

A private message is associated with this bug report

Honestly this is really annoying I can’t open any games :confused:


I am also getting the same issue here.

When i run roblox through the website to play a game, it instantly closes roblox after a few seconds making me unable to play any roblox games i want to play at all.

Sometimes, i can play a roblox game for 4 - 50 minutes by running roblox directly from the launcher and then choose the game i want to play. this doesn’t fix the issue at all since once it pass it just crashes or gives me an unexpected client behaviour error. then yes, i cant play / launch roblox anymore at that point.

I am also assuming that Byfron (or what they call Hyperion maybe.) is doing all of this causing the client to close itself or kick me out of the game.

System Specs
CPU: Intel Core i5-2500
GPU: Integrated Intel Graphics


For me I can play only on my main account unless I go through the app to log out for some reason pressing the log out button takes 10 or more minutes to actually work since it freezes the app for some reason. Then I can log into another account to play on it, trying to press play using the website on my alt just “upgrades” roblox and then closes.


This has been happening to me when launching Roblox after not launching it for a while. Attempting to launch Roblox again after it crashes doesn’t seem to result in another crash.

I’m on the ‘LIVE’ release channel, not the new 64-bit client beta.

The game crashed a few seconds after loading.

Closing the game also seems to leave the client running in the background where it proceeds to utilize nearly my entire CPU.


Hello Veov_Ekdosi,

Thank you for your patience. We suspect that the main issue is the rather limited memory on your machine. Could you please try to join Going Places - Roblox and let us know if you succeeded? Ideally, before doing so, it would help to close all unnecessary programs to conserve memory.


Hello Tsu,

To narrow the issue down, could you please follow the instruction I just posted for Veov_Ekdosi?


I tried to enter the link you provided and it loads the picture below, but I cannot move around or do anything, its frozen:

In my game, either it freezes when searching for an available server, or once it finds a server, it stays stuck in the lobby page with no UI loaded (menu screen), or if it loads and you click on a map, it gets stuck mid transport to a different map and never teleports. This all started happening about 20 minutes ago. My game link here:

1 Like

I was able to join for a moment, the exact thing that happened to @RMofSBI happened to me, it loaded the spawn and the baseplate, however the difference for mine is that it didn’t load the textures for the baseplate or the spawn, and then it instantly froze again, while I do have a limited memory capacity on my laptop all games on Roblox were running smoothly for me before this update including games like Frontlines which is usually very heavy for lighter computers, and while I am thankful that Roblox is trying to beat down exploiters I cannot understand why it’s caused this issue?

1 Like

Update: Ok I was able to fully load this time,

I don’t know what ya did but ya seem to have fixed the issue lol.

Update: my game still doesn’t load the menu screen (starting place), which is a ScreenGui… it just shows this instead:

It is a universe where the lobby is a menu screen where you can select your race map. It is just showing the baseplate instead of the screengui.

The link for the Going Places is now working for me however.

I have plenty of memory and a fast desktop as well, so I know the issue isn’t on my end.


As someone who has also been having a similar issue continuously over the past few days, I had to attempt about 8-10 times loading into this place before I had fully been able to join. This is also an issue I face with any other game, having to repeat this multiple times to get into every other place.

In most cases, my Roblox Client crashed itself before it even opened as an app, and in some cases it refused to even load the game entirely, freezing in the loading screen before crashing.

I’ve noticed that there seems to be a difference in how both the 64-bit client and the live client load assets (viewed through how the clients show themselves to open differently) and felt as if this is certainly related to the cause. Even without any apps open at all, I still am unable to join a place with a simple baseplate.

Though going back to the topic at hand, I was able to load fully into the game after my continuous attempts, and was met with the ability to both walk and move freely in the baseplate, unlike the previous cases above where the camera had been frozen.


I got similar experiences that I had to deal with for the past few days.

I have around approximately a 1/3 chance of getting an unresponsive, white screen, lasting around 8 seconds+ before crashing, and rarely an identical issue to the issue this topic is referring to.

There were also a few occasions the Roblox Player (maybe the new anti-cheat) called me out for “unexpected client behavior” when all I did was wait for the client to load the game.

I got 8 GB of RAM on my terrible laptop, but Roblox has always been running fine until a few days ago.


My Roblox Client updated while joining. but good news, i successfully got inside the game.

However, if i try to join another game, i have a 50/50 chance of crashing or joining the game successfullly.


I’m glad it worked for you. Please keep me updated if you face more issues.


I have 32 GB of ram but I have the same problem but its when I try to play using the website on another account than my main I’ve tried support but they haven’t responded in 2 days.

Pc Specs

32 GB DDR4 2133
GTX 1080
239 GB SSD


Hi Tsu and everybody else who is facing issues,
Could you please post a screenshot of your About page?

The About page should loke something like:

1 Like

like this?

my roblox just updated and now I literally cant play anymore
0.572.1.5720486 (bbb555) is the new version btw

1 Like

Hello Bitdancer,

I tried reporting this issue about 4 days ago when the new byfron update was released but the post was taken down for some reason.

Anyways, I tried joining the game and I was unsuccessful in doing so.


Hello Sam,
It seems that you are using the 32-bit client, and thus, the issues you are facing cannot be attributed to Hyperion. An updated client will be released in the near future, which hopefully resolves the problems you are encountering.


my game just updated and now im unable to open the game anymore or the app (not the windows one) but I can check the logs for the version which is 0.572.1.5720486
nothing happens after it says starting roblox it just closes
this is the 64 bit version I noticed that it would install a new version on my alt with a robloxplayerbeta.dll file basicly all I know is that the 64 bit version just crashes but the 32 bit didn’t I dont know if log files have anything like my account cookie or something like that but [FLog::Warning] UserAgentString Mozilla/5.0 (Windows NT 10.0; Win64; x64; Trident/7.0; rv:11.0) like GeckoRoblox/WinInetRobloxApp/0.572.1.5720486 (GlobalDist; RobloxDirectDownload) is set is the error I get in every log when trying to open the game in the 64 bit version.