Roblox hanging then crashing when entering sub-places


This is an issue related to the main Roblox launcher.
Something has been happening recently that I thought was just me until I ended up going onto other games. A brief summary:
Play a game that has a menu and teleports you into another sub-place
Go into that sub-place
Hang for a random interval
Crash to desktop.

I originally thought it was my own game due to it first happening there, but soon realised it affects other games. Here’s a video explaining what happens:

External Media

To help assist, I have:
Nvidia GeForce RTX 3060 TI, Ryzen 5 3600, 32GB RAM, Running Windows 11 21H2

I have Oculus software on my system that for some reason runs with Roblox at the time of writing (WHICH IT DIDN’T BEFORE) even if I don’t have a headset plugged in, and I have GeForce Experience. Those two are known for causing issues in the past from my research, so I thought I’d note that.

I have found that the Windows 10 version allows you to teleport to sub-places just fine, Just the normal Roblox program that is meant to run as a .exe, not a UWP.

I hope I am able to get an answer sometime soon as this seems to be affecting a couple of users, not just me.

Thank you,

1 Like

We’ve filed a ticket into our internal database for this issue, and will come back as soon as we have updates!

Thanks for the report!


I can vouch for this. Over the last week, I’ve had problems with teleporting to sub-experiences and/or leaving the experience to an extent.
Instead of seeing the loading screen or being able to navigate the main menu, the game client crashes and I am thrown back to my desktop.

The crashing doesn’t happen constantly, but it’s inconsistent to properly rate it’s occurring frequency. The impact overall is very high, especially because it can render some experiences unplayable.

A workaround is to manually stop Oculus VR Runtime Service under Services, or running sc stop OVRService in an elevated command prompt. This will shut down the software and prevent Oculus from opening itself when any VR applications run. More importantly, this will also stop the crashing.
(This workaround is viable only for Desktop.)

I tried that and the issue prevailed, so it might be something deeper into Oculus’ runtime or how Roblox handles it. I’m not too sure, to be honest, but let’s hope this gets resolved.

1 Like

Originally I thought the software was causing runtime conflicts. It turns out that wasn’t the case. My apologies.

I just tried that solution - I don’t check the dev forum that often - And it seemed to of fixed the issue! What a weird issue though - Microphone drivers crashing causes Roblox itself to crash? Definitely interesting to see why Roblox is depending on drivers. Not sure if it’s just the natural behavior of the client or what. Either way, thank you for linking this forward! This should be able to conclude and combine this issue into the other post.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.