Roblox Images Reverting

Ok so, i have images that im trying to change, but when i put in the id and publish, once i come back to the game, they revert to the older images, i’ve tried a lot of things to try fix this. Am i doing something wrong or is it just roblox?

New image

Image it’s reverting to

This is happening with all my images

It happened once to me when I set a texture for a part, but it was the wrong one so i had to do it again, but as it was the same name of the old one, it kept putting back the wrong texture. To fix this, i had to archive the old image in the roblox website. So if you are in this case I would ask you :

  • Are you using the image Despawn2 or is it an old one ?
  • Did you set an image with the same name twice ? (even if you deleted the old one with the view-game tab)
    If you are not using despawn2, go to your roblox account in the website and archive that image.

Hope i could help :slight_smile:

Well this never happened to me but try these

1.Delete the image label and put the image id or
2.Reboot your PC.

Did you check in console if you get any errors or if you have waited long enough so the version was completed publishing before you closed the studio?

Yes i have, sorry for the late reply, i was trying to do everything i can. If i publish, then i wait around 2 minutes and go back on studio they go back to the old one. The reason im trying to change these images are because they only show up visible on studio but don’t show up visible on the actual game which means nobody can see the gui

That could happen because of your Internet connection, make sure that it is stable. I suggest you change the Image value to 0 first, wait a few seconds, then put the new ID.

Ah haven’t tried that, i’ll try that right now