ROBLOX In Game Pointer Error on Apple Computers

In the past couple of months I, along with my other friends who operate on an apple computer have been having an issue inside games involving the mouse/pointer. The issue is that while you’re in a ROBLOX session, if any other programs were to be opened up automatically (ie; Receiving Skype Call window , Discord Call, Apple Update, or anything window that gives you a notification) you would not be able to move the camera around at all and the pointer would be stuck dead centre in the middle. The only way to fix this is to exit out of the ROBLOX client. Teleporting to other games would still render the pointer broken.

The bug happens nearly every time if you receive a Skype Call while you are in a game session. To replicate it, you’d only need to be in game and have another program automatically pop up to the front of your screen and in front of the ROBLOX window.

This is a video of the issue happening.

This has been happening to me and a few others for a couple months now and it has been really frustrating at times! I suppose now is any better time to bring this to the light!


YES. This happens to me as well. One method for resolving this for me was to swipe to another desktop, move the mouse around a bit, and return to the client. A very annoying bug nonetheless.


Yes, I have been recommended those as solutions but oddly enough it doesn’t seem to work for me. I have tried switching to different desktops. Tried opening up mission control and even switching mouses but it didn’t work. I was always forced to completely leave out of game and rejoin.

But even if there was a temporarily solution, it’d be even better if it was fixed completely haha!


YES, me as well. Unfortunately, the only solution I’ve found is rejoining the game. I’ve noticed that this issue also occurs when you interact with the border of the window, such as resizing.

1 Like

Really? Resizing the border/window works completely fine for me. It only happens when I get calls from other programs or another application asking me to update. Anything that jumps over the ROBLOX window will break the pointer for me.

1 Like

Yes, but not always. I am currently trying to find a repro that situation, will respond if im successful.

Seems to happen - at least to me - when you mouse over and click the window when its not in focus.

1 Like

I have this all the freaking time too. It feels like Roblox neglects Mac’s studio hugely. I posted this well over a month ago and bumped it, all Macs have this issue, and nothing has happened about it.


There are a limited number of resources we have at our disposal. As far as we know this only affects a single model but we aren’t able to reproduce this issue consistently enough to fix it.

1 Like

Dang that’s unfortunate!

I am easily able to reproduce my issue every time so maybe I could be of some help?

I’m just a bit bummed that this issue has been going on for months now and it hasn’t been fixed. It was an update that did this because this wasn’t always occurring. Hopefully soon this can get fixed. :frowning:


It’s been 3 years and I still got similar issues on this, I tried opening new program, but the pointer keeps freezing when I joined a meeting in Zoom.


Bumping this – it’s been almost 4 and a half years and it’s still happening.


SAME BRO. Studio is so hard to use lately when testing. Especially when testing something mouse based.


I’ve had this problem for so long! I remember stumbling on this forum post and sighing but I recently found a cure! If you press F4 for the “Spotlight Search” whilst in-game it fixes the stuck cursor, atleast that worked for me.


In regards to fixing this problem, I have found that opening Launchpad, then closing it while moving the mouse could also fix the cursor.
When I open and close Launchpad without moving the mouse, the issue persists.
If the mouse is moving when Launchpad finishes closing, the issue went away for me.

This issue is still happening, I have to close roblox to fix this issue and sometime I don’t want to leave the game because I’m in a match


Bump, Issue is still happening on M1 Macbook on Mac OS Big Sur

When the pointer moves out of the client window it will get stuck

I am unable to reproduce this issue on the same MacBook/OS. Is the issue still happening and, if so, are any extra steps necessary to make this happen?

I found a way to fix, if your cursor is bugging move the cursor out to your mac taskbar and move it back in roblox again

this sometimes happens to me on windows