Roblox Incorrectly Displaying Animations Imported from Blender

For reference: I am not using bones. I have tried using bones and got the same result, but it’s possible I did it incorrectly. The model only needs four parts to move on a hinge - something a normal Motor6D should be able to handle. I don’t want the whole model to be combined into one piece so I can individually color each mesh.

The animations appear fine in Blender, but when imported into Roblox through the character creator and then through the animation editor, the parts of the mesh that are suppose to be animating are moving with incorrect rotation values. Four of the meshes are completely gone, and there is inverted rotation when moving some objects the objects in the animation editor.

In Blender

In Roblox

Blender export settings (.fbx)

1 Like

I’ve found the solution:

Roblox only takes the first NLA track on the animator - NLA tracks can only apply to one object at a time, so in order for this to work you would need to have one object animating all of the meshes - the solution is to connect the whole structure together using bones without joining any parts. The previous animations applied correctly as I matched the bones positions to the original objects, and everything worked perfectly.

If you’re wondering how to perform this yourself, check out Blender’s official 2.8 tutorials on armistices.