Roblox installs the incorrect version of Roblox Player

Note: The issue still occurs for Roblox Player but no longer occurs on Studio.

PC Info: Windows 11, Version 10.0.25905 Build 25905
Date first experienced: 7/21/23
Date last experienced: 8/12/23

Reproduction Steps:

  1. Install Roblox or Roblox Studio
  2. Close it after it opens
  3. Reopen it and the error will occur

Expected Behavior: Roblox or Roblox Studio will run like normal
Actual Behavior: The error appears causing you to have to reinstall after every use

Every time studio or Roblox is reinstalled it works fine until I relaunch it. It says it is up-to-date in the launcher then show this error:


This is terrible for my workflow as I cannot work on multiple places at the same time which is needed for the game I am working on, without receiving this error.

I’ve had many issues like this with Roblox and Roblox Studio lately, one where I couldn’t play games on any device or network on my account but other accounts worked, and I am also still having an issue where I can only join games by joining servers directly, and another issue where I cannot be the first person in a team create session or colleagues will not be able to join.

Solutions I've tried that didn't work
  • Reinstalling Roblox
  • Completely reinstalling Windows (Physical USB & Remotely)
  • Creating a new user in Windows

The issue was caused due to me still being enrolled in the “zfeatureenablednewcsgapis” channel. It was resolved after a Roblox staff member force removed me from all channels.


data reset ur pc with saving files with new windows 11 update, or make new user account on windows

1 Like

Did you not read the solutions I’ve tried that didn’t work? Please stop replying to my posts you are not helping. I would block you if I could.


It would help to get more details about the version of Roblox you have installed. If you still get an out-of-date error when connecting to a game, open the Desktop app, go to the About section, and show the details that are displayed at the bottom.

1 Like


Seems odd for you to still be enrolled in that channel. What does this webpage show?

Also, try using this URI: roblox-player:1+launchmode:app+channel:production. You can paste it in either your browser’s URL bar, or in the Windows Run dialog.


Hello Frindow,

I have force-removed you from all channels. Please clear the browser cache and close all browser windows or even better, restart the machine. After that, the latest version of Roblox should be installed as soon as you open any experience.


It shows this:

I opened it using that link and it seems that it is up-to-date.

1 Like

Thank you, I’m no longer getting the incorrect version issue but am still having some issues.

When I attempt to join a game it says “Waiting for an available server” for almost 2 entire minutes then makes me join a server by myself which has limited functionality and after about 10 seconds it says “Roblox has shut down the server for maintenance”.

The only work-a-round is to directly join a server via the server page which takes forever if the game has a lot of players because I have to go through tons of pages of servers to find one I can join.

This happens regardless of my device or network so it is not an issue on my end.

Could you do anything on your end to fix this issue?


Hello Fridow,

I did some tweaking. Please try again. If you are still facing issues, please let me know. Don’t forget to close all browser windows before you try again.

1 Like

I closed all browser and Roblox windows and the issue still occurs, here’s a video of the issue:

When somebody else tries joining the server it says “Unknown Status”. Data store in the server does not work as well as other server sided scripts.

Hello Frindow,

Please give it a try once again. We found yet another place that pointed your user ID to the wrong backend channel


Everything seems to be working fine now, I’ll let you know if I have any more issues.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.