ROBLOX is killing my CPU?

Not much to say, I opened The Plaza by Widgeon and basically my computer started lagging so bad it was crazy.


I’ve been noticing an uptick in CPU usage also, and I’m having random people complain about lag problems.

Windows 10, Intel Core i3-3240 CPU @3.4GHz

Possibly related sidenote, both Studio and the client still insist on using my inferior GPU compared to my higher end one for some reason.


Are you sure that it’s not that Studio or Client updated? In my case, I can set both to use the dedicated GPU, but when ROBLOX updates they make new folders which means new paths to the exe files which means I have to set it again.

How does one go about that? Last time I tried I couldn’t get it to work.

I don’t know how things are set up for you.
For me, I’m using a laptop with both integrated Intel graphics and a Nvidia card.

Pictures ![](upload://if5YjuOTQm7VwukWnCKeoGp4YnV.png) ![](upload://xfBKE0pMuOmX0cWgXMjv6bxzoRE.png) ![](upload://pZT9MdaG9IZg1xu5BGISfD9EvkU.png) ![](upload://lnDUirUDVgz14p6SVmT8yyQ9EFW.png) ![](upload://xuVI8gmD5azq2hIbofRz2X36Hoy.png)

Oh hey thanks. Sorry for the thread derail.

Pretty sure we now use the dedicated GPU (at least for NVidia Optimus cards) by default… There was a NVidia driver update that broke that but I think this is not the case any more. Are you saying that without doing that the integrated card is still the one that gets used?

It is my experience that ROBLOX has not been using my NVidia card in Studio or Client without me setting it manually, as far as I’m aware. The only way I ever check this, though, is by looking for GeForce’s ShadowPlay FPS Counter, which I leave enabled. (I’d like to note that this was taken after manually enabling Studio to run on the NVidia GPU, if I don’t set it manually this doesn’t show).

Going to Studio Setttings > Diagnostics, it shows this.

I don’t know if I have NVidia Optimus. I haven’t seen it in settings or anything.

If you would like me to get you any more information, I’d be happy to find it and get it to you.

I am not sure the info updates.

Images ![|672x221](upload://bO8JDocwzPaAL6m4LwXTzYXNwGW.png) ![|690x250](upload://ayoorUjcbN8ojQf0RrXwjtVlJl6.png)
1 Like

You’ve prompted me to check somewhere else for this information. It seems that ROBLOX is running on the NVidia GPU! I had to enable the icon to launch this again, for some reason it got disabled.

Picture ![](upload://6Oy8gbPeZadL4CiBiTAcZPKu3rI.png)
@zeuxcg It's working as it should be, it's just hard to tell. I don't know if Studio should be reporting the integrated graphics card though, so that might be a bug.

Yeah, the Diagnostics thing reads GPU data from a completely unrelated source. Which is sort of a bug.

ROBLOX is melting my CPU whenever I join a game


What types of games have you been seeing this issue on (other than The Plaza as the OP said)? I have only gotten about 10% usage by Roblox on an i7 4700MQ and i5 4210U.

I can only assume berezaa plays Azure Mines atm :stuck_out_tongue:

I can confirm my players for my game are seeing this same issue too.
Since I don’t get the same issue happening on my end, I can’t make a detailed report on it.

I’m not getting this blob.png

I actually have a similar problem with you, for my work laptop. However it’s something to do with my NVIDIA card

Processor: Intel® Core ™ i5-4210 CPU @1.70GHz 2.40GHz
RAM: 16 GB
Dedicated Card: NVIDIA GeForce 840m (a netbook card from the 800 series)

Here’s what I’ve done to try and fix it:

Disabling my integrated graphics (Intel HD Family). When checking on studio settings to see if it works, studio just uses the default built in windows basic graphics.

Updating my drivers, and downgrading my drivers, did nothing.

Running in compatibility mode did not work.

Using different rendering settings made no difference (just messing with them, swapping between OpenGL and Direct). Resetting didn’t fix it either

NVIDIA control panel says it should be using the card, and I’ve tried going on to every stored version of the launchers and manually putting them to use NVIDIA. Still using Intel card - I know this because I can average 60 fps on 10 graphics with it, and now I can only average 60 fps on 1 graphics. Also, you can check the GPU activity, and it doesn’t show it running for ROBLOX. Studio still says I’m using the Intel card.

Tried making my laptop use the NVIDIA card for everything that needed it. Didn’t work, just decreased battery life because of my other applications.

Any ideas? This has only happened for the ROBLOX launchers thus far, other games work fine with the card :frowning:

I don’t know if this is an indication of the problem - I don’t understand this graph at all. :-/

I currently (on Win10) have a 100% CPU utilization according to this graph, and Processes tab says that ROBLOX is at 50% utilization. The Details tab however says that ROBLOX is running at ~5% CPU utilization - which agrees with our internal metrics.

And if ROBLOX is not running I still get 100%, with Chrome accounting for most of that - which is just incorrect. Process Explorer by comparison shows numbers that actually make sense.

So that percentage seems to be relative to some unknown value.

This could just be my PC but this does not exactly inspire trust in the graphs you guys are posting.

1 Like

My friend also has a higher CPU usage than normal, usually he can play phantom forces no problem, but for some reason its laggy and has a high cpu usage.

He has a NVidia 980 GTX