Roblox opens and loads for about 1-5 seconds then crashes!

What’s happening?
Unfortunately this has been occuring for me for nearly a year now. It started in April after the Anti-Cheat update. When I go to launch Roblox it loads perfectly fine (most of the time) then freezes and closes. 100% Of the time I can’t even get passed the loading screen for a game; When launching just the Roblox Player via start menu it loads (Names, games, icons, friends and the home page), then freezes and gives a pop up stating “An unexpected error has occured and Roblox needs to close.”.

Video of what happens

Sorry for the messy desktop, I hardly clean it since I never close out of all tabs.
This was after a fresh reboot and reinstall after removing the registry files, the Roblox file in Local, and uninstalling the app.

What I’ve tried
Uninstalling (Removing Roblox app, it’s file & registry file.)
Uninstalling MSI Afterburner
Closing all non-essential apps on my computer.
Updating graphics drivers & Windows.
Restarting PC (before reinstalling)
Disabling all non Windows services & apps then restarting pc.
Launching on a new user.
It can open on the Microsoft store version but not the launcher.
Runnning Malwarebytes (To remove malware & other viruses), didn’t work.
New graphics card (not because of roblox just a recent pc upgrade), didn’t help.
Reading the Bitdancer post on Hyperion related crashes (non have helped).
Clearing thumbnails & other disk cleanup settings.
And a few others I can’t remember right now.

I have been extremely frustrated about this due to the fact the Microsoft store version doesn’t have VC, Camera tracking, and is extremely unreliable and bad with 2 moniters.

If you’d like the dump file just tell me where to find it, I can’t remember where it is lol.


Are you using a cloud gaming pc such as shadow tech?

1 Like

No, my pc is custom built.
Specs in-case this helps:
RTX 4060 Ti 16gb
Ryzen 7 3700x 8-Core
32 GB Ram
2 1TB SSDs
1 500GB SSD (Main drive).


Do you have windows pen and ink at all, I saw in another post that can possibly trigger something, not sure if still the case.

1 Like

I don’t have one, though I’m not 100% sure if the Windows pen & ink workspace being enabled can cause issues, or how to disable it.

1 Like

I recommend reaching out to Roblox, or posting a bug report #bug-reports

1 Like

I don’t have access to #bug-reports
I’ve reached out to them and everything they said did absolutely nothing.


This exact issue began happening to me around a week ago, after almost a month of not playing Roblox. I tried all the steps above, with none of them working either. This is unfortunate because the UWP version of Roblox works fine for me however it’s very glitchy and I would rather simply not play the game entirely.

Same feeling here, I’ve gotten Roblox to load into Tower Defense Simulator for about 10 seconds, I can move around and interact with UIs. It takes a long time for textures and other assets to load IE: Player models, meshes and ui images. Then when done doing that the game freezes then closes. When I contacted Roblox about it they told me to do the simplest troubleshooting, then told me that it was forwarded to their technical team. Haven’t heard anything since. That was about 5 months ago.

No idea if you’re still having problems with this, but can’t you just try ignoring the pop-up?

After about 5 seconds of the pop up showing it automatically closes.