Roblox Player freezing on install with Windows 11

My friend got a new PC and tried to install Roblox with the latest installer, but it kept freezing on install. I was able to replicate the issue when I uninstalled Roblox and attempted to reinstall without connecting to my VPN. However, the installation works perfectly fine when connected to a VPN (I have only tested with this one, though). I don’t know if this issue is due to a new Roblox update, or maybe Windows 11.

Steps to replicate:

  1. Ensure no VPN is connected
  2. Download the latest RobloxPlayerInstaller.exe from the Roblox Download
  3. Run the installer
  4. It should freeze at some point during the install and stop progressing.
  5. Close the installer with Task Manager
  6. Enable a VPN (I’ve only tested with this one)
  7. Attempt the Roblox install again
  8. It should install without problems.

Here’s a video:

I had to cut the video short because of a Google Drive storage limit. I tried waiting for 5 minutes, but the installer did not progress.

I can also confirm this is not an issue or specific setting on my Wi-Fi network (I checked). Additionally, my friend also experienced this on another separate Wi-Fi network.

1 Like

Since you say it works when you use a VPN are you sure your router, computer or network provider isn’t blocking a signal? Are you using software such as GlassWire to monitor network traffic?

Also isn’t a VPN but rather a DNS database this means it is like a database that links to for example. Therefore your issue seems more like your DNS database which goes in order of device > router > network provider > public DNS servers. I recon there must be an error somewhere along the line where a DNS database is caching an incorrect IP address for or * or any other domain which Roblox use in Roblox Player

1 Like

I’m not using any services to monitor network traffic. As stated in the post, the issue happened on multiple Wi-Fi networks. I tried using some other Wi-Fi networks (like cafe wifi), same result.

Because this seems to be an error with your DNS try running:

ipconfig /flushdns

in the terminal/cmd.

this happened to me 7 days ago and today i have the same problem as you also i am using windows 10
in my opinion, this issue only occurs on Windows 10 and 11

Thanks for the report! We’ll follow up when we have an update for you.

Tried that just now, didn’t fix the issue.

1 Like

Update: It appears something has changed, as the install functions without problems again. Could just be me, however.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.