ROBLOX Player Launches Twice, Doesnt Open The Game/Display




Processor 11th Gen Intel(R) Core™ i7-11800H @ 2.30GHz 2.30 GHz
Installed RAM 16.0 GB (15.8 GB usable)
Device ID 5A8CCA73-8B66-4514-9648-12EAA40AD13A
Product ID 00342-20703-50468-AAOEM
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display
Windows Specifications
Edition Windows 11 Home
Version 22H2
Installed on ‎1/‎11/‎2023
OS build 22621.1992
Serial number PF36K7L9
Experience Windows Feature Experience Pack 1000.22644.1000.0

The above were copied from the settings application.

What happened:

  1. I updated ROBLOX studio, and tried to open ROBLOX player where it auto-updated. Shortly thereafter, it displayed an error message that the file was corrupted.

  2. I fully deleted ROBLOX (Studio, Local information under AppData, all ROBLOX players under file explorer). I then used the windows settings to uninstall ROBLOX (it still had something downloaded somewhere that opened up).

  3. I tried reinstalling ROBLOX through the website where it downloaded fine, with no errors.

  4. However, upon attempting to open the application (through the browser and file explorer), the application opened up saying “Starting Roblox”, for 2 or so seconds, before a separate window opened that said “configuring ROBLOX” and then switched to “Installing ROBLOX” (the install bar finished in half a second). After that the “Installing ROBLOX” window closed, showing the original window still displaying the message: “Starting ROBLOX”. It closed seconds after and did not open up the actual game/usual display.


This may not help very much, but I found a half work-around (allows the display with games and all that to open, but not the actual game).

Steps Taken:
Turned off Wifi.
Opened ROBLOX player through files;
After loading a few seconds, turned on Wifi;
Clicked Retry on the notification about lacking internet;
The display appears;
Attempted to join game;
Given error message about ROBLOX needing to update;
ROBLOX Player does the same thing as in original video.


Log/dump files were attached to the internal ticket by a Roblox Staff (@Focia19), due to the sensitive information they may contain, will not be shared publicly!


Just to add on, it looks like I am using the 32-bit client:


Seems I can’t view the video


No, Roblox’s launcher is 32-bit. Client itself is 64-bit

1 Like

Thanks for the clarification. I did think it weird that I would have been on the 32-bit if I was using the website downloaded application.

1 Like

Thanks for the report! Just to confirm, we have a ticket for this in our internal database.

Same thing happening to me after a couple months of the first report.
It doesn’t launch twice but instead the Roblox Player process runs in the background forever

1 Like

Unfortunately, the computer that this was being run on broke (almost certainly due to overheating; nothing to do with this bug). Therefore, I am not able to replicate this issue any further. My current computer runs ROBLOX completely fine (albeit with worse graphics due to a downgrade in graphics cards).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.