Roblox Player No Longer Launches

Attempting to launch the Roblox Player displays the Starting splash screen for a few seconds

The splash disappears and nothing happens

Roblox Game Client shows in the Task Manager for a short period and then disappears

Nothing ever shows in the toolbar

Studio is not affected and launches fine
Rebooting and reinstalling entirely do not solve the issue


Looks like it’s not only for you. I think it’s because they converted into 64-bit (maybe) and by this anti-cheat (idk). I am waotibg for like almost 2 weeks when they will fix that.

P.S. The possible way to play Roblox after this update is by using Roblox from Microsoft Store.
I know that there are some bugs with first person mode and something else in it, but I think it’s better than waiting 1 month to play Roblox. :slight_smile:

1 Like

Thanks for the report. I filed a ticket to our internal database.


I’ve also been having this issue and I’m not sure why it’s happening. Hope it gets fixed soon as it’s quite frustrating.

This has been going on for 3 weeks now on my end

I tried this solution. It worked for me although it still crashed or closed itself when I joined two or three games but then it worked again

1 Like

Same. Deleting the Roblox temp files allowed me to open the program, but it freezes after joining any game

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.