Roblox player not opening at all no matter what

I just got a new PC and Roblox refuses to open for me. Opening from the browser doesn’t work, opening the player itself as an exe doesn’t work either and bloxstrap didn’t help. I’ve already reinstalled a few times, including completely from the appdata folder but it just refuses to open at all. This is really weird because it has never happened to me, changing browser won’t work because the issue lies in the player itself, when I launch it from the Windows start menu nothing happens, even as admin, but opening it in the appdata folder does show something but that’s it.

Edit: I tried the app from microsoft store and it just crashes after 2 seconds… What is happening?? I can’t play roblox at all on this PC…

The problem is maybe your firewall not letting Roblox launch. Try setting Roblox like this in the firewall app (windows) :

In the firewall app, find the section “Outbound rules” and in it, find Roblox. As you can see, the collumn called “Activated” or other in your language OR the collumn that the red arrow is showing must be on “Yes”. Try after that relaunching Roblox.

I don’t know how but it just fixed itself after a day… Even the store app doesn’t crash anymore, no idea what happened but it just works now…

Hello creator I’m @boxer78990 How can i help you @transam33o?