Roblox Studio Coloring Function Help

Hello, I’m going to get straight to the point and say that there is some feature that I must have accidentally activated in studio with the coloring option. Normally you would select all the parts you want to color and then click the icon that says “Color” in the home and models tab and all the parts would be colored.

My ROBLOX studio currently is not letting me do that and is making me click the “Color” Icon and then a paint bucket will replace my mouse button and I have to manually click each part to paint and I have looked into my settings and tried finding the properties for the paint bucket, I also uninstalled and reinstalled studio but I can’t find a way to turn off this function.

Here is an example of what I am talking about:


You need to go to view and then click on porperties.
Then find the model u want. Expand it so you can see the specific part u want to change the color for.
Then while the model/part is selected via the properties tab.
Click on the color you wish to change.
You can have the properties tab open and at the top of the properties tab you should see something that says background color or something that has color in it.
Then choose your color from there.

Hi there!

Have you tried popping into the settings menu and clicking “Reset All Settings”?

Thank you, I know about the Properties tab , but the problem is with properties is that you have to select every single child in the model in order to use properties to change the color whilst the color function in the home and model tab automatically select all children if you click the model and colors it.


I tried resetting all the settings, still didn’t work. I tried asking for some help in Hidden Developers but no one is having this same problem and there is really no way to search for it on the internet…

Open your properties view please.

did u know that u can select multiple objects when u hold down shift or ctrl.
when u use shift just click the first part and the last part then it will automatically select everything in between. Then you use the properties tab to change the color.
Or you can use ctrl for certain parts to change color


I know about the properties tab, I have been using studio for 6 years; this problem has just showed up and it’s really bugging me. I want to be able to select the model/part and color it. When you select the model in the Workspace now, it requires me to manually select all the children that are BaseParts and then use the properties tab to color it which I do not want to do because there are some models that have scripts inside and when I click the model and click the Color function in the Models and Home tab it brings up a paint bucket and requires me to manually click every part to paint.

Alright, I actually just figured out what the problem is, so on the bottom right side of the Home tab, there is an icon that contains a 90 degree straight edge with a diagonal arrow and if you select it, it pops down “Material Action as a Tool” and “Color Action as a Tool” and it has to be selected at Material in order to select and color and if it is selected at Color Action, it will require you to physically click and paint each part like a paint bucket.



I may be stupid, but it isnt working for me.