Roblox Studio continually freezing up when opening a specific game

(Apologies if this is the wrong category - it’s the closest to the issue this post is about)

I’ve just started having this issue where I can’t open a specific game in Studio. It may be due to the extreme size of the game, as it freezes a few seconds after starting the loading process. I can see some parts appear before the screen tints white.

I’ve also tried closing every possible background process to free up some space, however, this didn’t help in the slightest. Opening up any other game works normally. The game that has this issue has Team Create disabled and is Public, but the version I was working on is not published.

It was working just fine the other day (approx. 12 hours ago). I didn’t add anything significant to the place that could have affected this.

Operating system: Windows 11

Here’s an image of how it looks before prompting me to stop the program:

(notice how only parts load in, meshes aren’t finished loading in and only TextLabels appeared)
(maybe Studio is having issues requiring the IDs for this place?)

Any help would be greatly appreciated! I can provide further details if necessary.


I had the same problem 1 hour ago, but its working fine for me now
If it happens to many times try reinstalling roblox studio

1 Like

Okay, thank you. I’ll have to check in a few hours too.

1 Like

Or wait some time which is 2-5 minutes (worked for me)

1 Like