Roblox Studio Crashing on Startup

Roblox studio is currently crashing every time I start it up regardless of what world I try to edit. I noticed this at about 4:50 pm Pacific time when I attempted to load one of my worlds. I had been editing another world at the time without issue. When it crashed the first time I closed both worlds and restarted my computer. It has continued to crash every time I open studio. In case this matters, I’m using a Windows Surface Pro 3 running windows 10.

At this point, I’m at a complete standstill as I can’t edit anything.

Here is a screenshot of the error:


The correct tag instead of [URGENT] is [ROBLOXCRITICAL]. And that’d quite odd, I use that exact same PC and OS as you and I don’t have this issue. Maybe it’s an error in your version of Studio?

Didn’t realise this was bad enough to be critical. I’ll fix that.


Yes, the same thing is happening to me. Here’s what I found out about it:

It works for published places (if you click edit on the website) and this only occurred on saves files. I also figured out (something I’m not 100% sure on), that a few of my save files that did and did not work. From what I know, any place that has a “LinkedSource” script didn’t work for me, but that could have just been a coincidence. Care to share if that could be related with your issue?

I saw a visual change with the “Game Explorer” right before this started happening, so thats why Im assuming it was something to do with LinkedSources

1 Like

This is happening to every world I open, both published to roblox and saved locally. I don’t think I have used “linked source” once in my entire time on roblox so I’m pretty sure it’s not that.

1 Like

Hi Mimi_Dev,

Can you include the place link as well when you can please. Same for everyone else experiencing the same issue.

1 Like

This is happening on every place I open EXCEPT for “Team Create” places

1 Like

When I try to edit my place, I immediately get the “ROBLOX has encountered an error and we have to quit” dialog. All of my saves refuse to open and I am also unable to open it both via the website and .rbxl local file. This happens every time, and it’s the first time I received this (haven’t touched my place in a full week).

Link to my game –


It’s all of my places both published online and saved locally but I’ll link one anyway. I just tried to edit this one and got the error:

I cannot reproduce this on Windows 10 Pro with the latest Studio version installed (0.302.0.141582), using any place that is on my own profile.

Please provide links to places where they break for you and detailed information about your device (OS, studio version, place links to places which you cannot edit at the moment).

Noob question: Where do I go to find the studio version?

“File” > “About Roblox Studio”

Current Studio Version: 0.302. 0. 141582
(I also don’t know where to find information about my OS so if anyone knows???)

This does not qualify as ROBLOXCRITICAL:

Reproducible crashes refer to the game or website, rather than Studio. @Mimi_Dev Can you please edit ROBLOXCRITICAL out of your title?

Edit: ROBLOXCRITICAL rules were updated just for this bug. You can re-add it to your title @Mimi_Dev – sorry for the confusion :(

Thanks everyone we are currently looking into this issue. We will update this thread once we have more information.

1 Like

This should be fixed now. If not, it should work after a restart.


Thanks! Was having the issue an hour ago but now seems to be working again! :slight_smile:

Yes, it works now. Thank you so much! :slight_smile:
Edit: At what point do I change the title to “Resolved”?

The solution checkmark will appear next to your thread’s title in the forum listing, so you’re all set – no further action required:

Thank you for reporting this so it could be fixed so quickly:)

Your welcome. This was my first thread so I was a little bit confused about how to do it, but now I know :slight_smile:

1 Like