Roblox Studio Lag

Hello, im bat and im building in the roblox studio for sometime now.
I have been building my homestore for the past 2 days and everything was fine and there was no lag. Today, when i was about to complete it, there was a massive lag. I was not even able move around or even select a object/part due to the massive lag.
The lag started when i started duplicating and moving the stores(I think because of the number of parts). I read others posts too before creating my own post, they all never helped. I wonder if anyone here is having the same problem as me and have a solution. Your response are appreciated even if it doesn’t help, i will try each of your solutions till it solves the problem.
Also, excuse me if my english is bad.
Thank You So Much In Advance :slight_smile:.

2 Likes

It might be because of the parts as sometime there is to many parts and it might lag, try grouping as much things as possible.

1 Like

When studio is loading in a lot of parts I tend to lag sometimes so thats probably why.

4 Likes

That is very true, but if it shouldn’t take that long. There might be many parts but still it should not take over like 3 minutes.

1 Like

I am on the studio for more than 2 hours and i could only move around 3 cm for every 10-15 minutes or more. So its not the normal start-up lag.

Grouping parts doesn’t really do anything besides organizing your explorer, in fact, it actually adds data to your game because each group is another table studio has to work with.

@batman771177 Have you tried re-starting studio, or maybe re-installing it?

1 Like

Oh, i didnt know that it doesnt help and started grouping my parts. Anyways, i’ve started restarting and reinstalling my studio many times and ill try it again.

It may also just be that you don’t have enough RAM on your device to handle the load of duplicate all those parts. Could you post your device specs here? Also, if RAM isn’t the problem, you could try lowering your graphics settings in studio via File -> Settings -> Rendering -> Edit Quality Level -> Set it to Level 01

1 Like

I’ve also set the edit Quality Level settings to level 1.

Sometimes, if you accidentally put a Humanoid Instance in the Workspace, it makes the game lag intensely when you are Raycasting or sending signals from the Server to the Client

1 Like

Unions cause a significant amount of lag. Never keep unions. You should always export them and import them back as meshes.

2 Likes