Roblox Studio not launching on iMac M1

PC Info: 2022 iMac (M1 Chip)
Impact: Hight
Frequency: Consistent
Date First Experienced: 29/06/2023
Date Last Experienced: Now (I can’t really check because it is my grandfather’s iMac and I am at home right now).

Reproduction Steps:

Expected: Roblox Studio opens
Actual: Getting this error:

More specs about that PC:

I tried to reset it completly and reinstall Roblox Studio but it was still not working.

Thank you for the help in advance :blush:

Hey there!

Is this install of Studio somewhere other than in the /Applications directory?

Hi! :wave:

I dragged the Roblox Studio app into the /applications folder and ejected the disk but I was still getting the error.

OK I’m not sure dragging the Studio app itself would solve it but I do know that “bad things” are known to happen on Mac if Studio isn’t installed and running from /Applications

Just to be extra safe, my recommendation would be:

Open a new Finder window

Search for “Roblox” and delete the Applications

Empty Trash

Download Studio from

Run RobloxStudioInstaller


Once Studio starts up, Eject the installer and delete the dmg

Use the Finder search to double check Studio is installed in the Applications folder

1 Like

I tried that a bunch of times but now it is somehow working. Thanks.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.