Roblox Studio Not Working

Hey developers! My Roblox studio is not working. When I try to move a part it just goes to the end of the baseplate. And the moving, scaling and rotating don’t work either? Is this a bug? Is Roblox testing something? Please let me know.

I am working on something important that is time sensitive

1 Like

Sometimes studio glitches out like this. Try restarting the app. If that doesn’t work, restart your computer.

1 Like

Probably because you have your settings way up, go to Model > Rotate/Move and lower the values:
image
And instead of dragging try using the move tool(it’s more accurate).

1 Like

I have tried restarting app. No such luck.

My settings are literally 0.2. My rotate is 1.

Try restarting your pc. If that doesn’t work, try moving it from a different angle.

Ok thank you. Will do. Will let you know.

Ok it is working now. Thank you guys :desktop_computer: :smiley:

Also why is roblox studio different? The GUI for building is different.

I agree some thing is off. I was trying to rotate an arm on my friends account and it looked like this. Ive never seen it before.

So I’m having a similar issue. I’ve noticed over the past 3 days In Studio It’s no longer possible for me to pan/zoom when holding down the middle mouse button. It pops you all over the place. A lot of the time it takes you down below the 0 Y level. Also, over the past day, I can’t move/scale any object. Whenever I select it, it moves/scales/ randomly or snaps back to the original position/scale. I don’t have snapping enabled but I have tried enabling it at very small values with no difference. Basically, studio has become completely unusable for me. I’ve restarted studio/PC numerous times and nothing changes. I updated my graphics drivers and nothing changes. I’ve tested it with a fresh game/baseplate and nothing changes. I’ve never had an issue within studio before the latest update. Oddly enough, It doesn’t do it when I record, which is why I didn’t attach a recording.

I also noticed after looking at the previous comment that my controls have also changed the way they look, so I’m sure this behavior has something to do with the last update.

Any suggestions?

Possible some bugs that studio will fix. Ive had similar problems but with discoloration. Tabs such as View or the UI tabs have darker text font in witch I could barly read.

Wow, I certainly hope so. I’m basically dead in the water.

1 Like

We’re not aware of this problem as it is. Could you give making a video of what you’re seeing another try (maybe with a cellphone camera instead) and post it in the Platform Feedback section?

I was able to capture video of the issue from within Studio. Iv’e attached the files.MoveObject.wmv (294.5 KB) Panzoom (1).wmv (1.7 MB) robloxapp-20200912-1051358.wmv (1.5 MB) ScaleObject.wmv (458.6 KB)

Do you by chance have an XBox controller or other game controller connected to the machine in question? Try disconnecting it and see if the issue is solved.

Wow that was it! XBox controller. Is this a Roblox issue or Microsoft? I never had this before the new object controllers were implemented.

Thanks so much for your help!

You said that this just started happening recently? What was the exact day you noticed it? And had you used the Lua Draggers Beta before they were force rolled out on Friday?

I noticed it on Sat 9/12. I didn’t notice the Lua Draggers until yesterday in this post actually. I probably didn’t notice them between 9/12 and yesterday because I was hardly using studio in that time frame due to the pan/zoom issue. And no, I definitely wasn’t using it in beta.

Thanks to @ORLANDOMAGIC00. I saw a post about that by @bulgee and he said “You have the local on do CTRL + L to turn it off.” Hope it helps. :slightly_smiling_face:

1 Like