Roblox Studio UI warps, result makes it impossible to publish,upload,open game settings, etc

Reproduction Steps

  • Open any game or local file on studio.
  • Attempt to publish/save model, publish/save game or open game settings
  • See UI padding/positioning warped

System Info

OS: macOS Big Sur 11.3.1
Device: Macbook Pro 16’


Enabled Beta Features

All which are available (though this still happens if they’re all turned off)

  • NB - I have also tried this while disabling all plugins

Expected Behavior

When any option that opens up a popup window is toggled (eg publish, save, gamesettings, animation editor etc), the ui should be scaled/padded appropriately.


Actual Behavior

Upon pressing one of these buttons, the UI popup window opens as expected, but it is offset to the bottom left by 0.5/0.75 times it’s width and height.

  • NB - The UI is still usable to a degree, I can press buttons that are visible, but 3/4 of them are obscured



Workaround

Nope : (


Issue Area: Studio
Issue Type: Display
Impact: Very High
Frequency: Constantly
Date First Experienced: 2021-08-26 00:08:00 (+01:00)
Date Last Experienced: 2021-08-31 16:08:00 (+01:00)
A private message is associated with this bug report

3 Likes

This appears to be a bug with Plugin GUIs more than Qt. Have you tried seeing if this happens on plugins that use widgets.

This is an issue with QWidgetPluginGui instances, after some tests with the OP in DMs, it only happens for them.

For anyone who doesn’t know, quite a few of Roblox’s Tools use the Lua API, and they use an internal version of DockWidgetPluginGui named above.
image

3 Likes

This is likely an issue regarding whatever rendering library Roblox is using on your system. As a potential workaround, in your Studio Settings, under Render, try switching Graphics Mode to Vulkan if your GPU supports it, or try switching to Metal explicitly (since you’re on MacOS). If neither work, you could try setting it to OpenGL as well.
image

A similar issue happens when using the Windows DXVK libraries (Which is a DirectX -> Vulkan translation layer). They replace Direct3D 11 and 9 (which is usually done under Wine since DirectX support is not very performant under there), and the effect is that all plugin GUIs flicker with other viewport contents.

THANK YOU! This fixed it, I flipped it to a different graphics settings and it’s sorted

Awesome :smile:
If you’re able to, could you find out which Graphics Mode gives you the issue? I’m not sure, but, I believe Metal is generally the default on MacOS. Switching modes is only really a workaround, so, this may still be an actual bug under Roblox’s Metal shaders for example.

Open GL was one of the problematic ones, I cant remember what it was initially though.
Might just be my computer/os where this occurs though

1 Like

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

1 Like