Roblox Studio Union Glitch..?

Studio union bug has been fixed and has no further problems!


There was a post like this, I think this is a bug.

1 Like

Yeah, right after me writing that I noticed it. It’s 100% considered as a new bug because I use unions all the time and this is a first, but thank you. :smile:

1 Like

This is an old bug, just use blender. Forget about unions until this bug is fixed
EDIT: clearing my roblox temp folder actually solved this once, but never again.


Happened to me a week ago, what I did to fix was reverted place version a bit where I created it don’t know if it will work for you but it’s worth a try

using blender isn’t really a solution as it takes time to learn it and even more time to be good at it

this is a problem on roblox’s side, just hope they fix it soon because this bug has already been out for a while and developers potentially losing hours of work is unacceptable


You can try to turn on ReloadAssets under Settings>Rendering. I haven’t had any issues so far after I’ve turned this on.

at the moment blender is literally the only solution if he needs to build such models and not use unions. I don’t think it takes that much time to learn how to make a few low-poly rocks in blender

I mean, I have tried to move onto Blender in the past and it was a hard time.
So I decided to stick with Studio.


Hi, I just tried that method and unfortunately it doesn’t work. A lot of people are saying it’s just a Roblox glitch so hopefully this can all be fixed soon.


Thank you.

I once had that glitch too, it probably occurs by undoing/redoing in Studio.
I could get it fixed after reverting it to an older version, when having the game uploaded some more times before that glitch occured when testing the place.


Should be fixed as of March 17, 2021