Roblox system messages don't appear after having teleported with a custom loading screen

Roblox system messages (the ones that appear in the red bar at the top of the screen) don’t appear after having been teleported to another server with a custom loading screen GUI. This includes player kicked messages, loss of connection, server shutdown, and teleport failure messages.

This bug happens to everyone consistently in my places that use a custom loading screen during a teleport. It only seems to happen when the teleport is initiated in server code. Calling TeleportService::Teleport locally with a custom gui will usually still allow the messages to work (but not always), but when called from the server, it will never work.

This behavior is consistent with TeleportService::Teleport, TeleportService::TeleportToPlaceInstance, and TeleportService::TeleportToPrivateServer when called from server code.

Bug repro game:

  • Join the game. Press the “Kick” button to see that it works without teleporting.
  • Join the game again, but press Teleport.
  • Wait for the loading gui to appear and then disappear once in the new server.
  • Press the “Kick” button once more. You will be kicked (can’t move character), but no system message will appear.

To reiterate, this bug cruxes on the custom loading GUI. If no custom loading GUI is passed, then this bug does not happen.


I timed out because of being afk today, and the kick frame didn’t appear.
So thats what happened…

Bump still not fixed.

Can this get looked into? It’s still not fixed. System messages are very important to us developers because they help prevent the players from thinking that it’s the developer’s fault.