Roblox unable to download sound data

Hello . So yesterday, I uploaded my ak47 audio to roblox . When I tried to use it, it return this error to me Failed to load sound rbxassetid://13695827818: Unable to download sound data . I could not even view the preview . The same error is return even today when I try to play the sound.

It also happens to all my audio that I uploaded last time


Try reuploading the sound and make sure that you have the right ID

If the audio is moderated or you have missing perms it won’t load.

what do you mean by missing perms
also I did not receive any warning by roblox

I did try to reupload but same error happen

You don’t always get a warning. Does the audio a thumbnail other than the sound icon?

If the game you are developing isn’t owned by you you must grant the sound permission to in sound configuration.
That can be done by entering universe ID

it have the music icon/ two semi quaver

the game I am developing is own by me

Make sure the ID you have entered is a valid sound ID, if you did that show me the part of code where you try to play the sound. I don’t think you can make any mistakes in there but I rather check it


1 Like

The sound ID is defiantly valid unless there is an error in the code making of roblox studio that is very unlikely because I go ToolBox>Creation>Audio

Are you sure the audio has been approved by roblox already?

Make sure on the audio asset that you have actually saved the changes and/or added the experience into the list. By now the audio should have already been approved.

It should be because a day had gone by

where did you get the universe IDs from? I cannot find that screen

yea I know that is the game Id but what am i suppose to do with it?



oh wait my bad it is the audio id