Roblox Universal App BREAKS If Choosing an Emote with Rthro at EDIT PROFILE PICTURE

Reproduction Steps

  1. Log in to the Roblox universal application;
  2. Go to the Avatar section and customize your character;
  3. At Characters, select the option Purchased and pick a Rthro bundle (for instance: “Riley”);
  4. Return to the main background of the page;
  5. Go to Edit Profile Picture and select an emote.

Expected Behavior

Expected that the feature would show me what the emote would look like if used for my current Rthro avatar.

Actual Behavior

In the actual state, the avatar would be buggy and wacky, especially with wearing layered clothing. If returning to the main page, your character still displays a broken perspective and, sometimes, appears infinitely in the loading bar.


Thanks for the report! We’ve filed a ticket in our internal database.


Questions for original poster:

  • Is this still happening?
  • Does it happen every time or just sometime?
  • What platform are you on (iOS, Android, XBox, etc)

Hey, @CycloneUprising!

Yes, the bug occurs all of the time and anywhere I log into Roblox, for instance iOS, PC, etc.

1 Like

@CycloneUprising Are there any updates regarding the bug?

1 Like

I have a fix checked in. Waiting for it to clear QA, be release to production, then I can enable.

Thanks so much for reporting this and helping to drive a solution.


Heya @CycloneUprising !

Were you able to update the production? It has been one month and I am quite curious if the issue was solved :astonished:

I apologize that this has taken so long: as the company grows the pipeline to get things properly integrated, tested, and released has gotten longer.

That said, I just turned on the flag supporting the change and it seems to work. So if you restart your roblox app you should see the problem fixed.

Thanks so much for catching this issue and bringing it to our attention!


Thanks for the update @CycloneUprising! :slightly_smiling_face:

I took a look to see if everything was solved and it seems that we have the problem remaining, but worse! :skull_and_crossbones:

As wearing the skinned mesh avatar and selecting emotes in the Edit Profile Picture area, none of them integrate the expected poses… The character stands still and only changes the facial expressions.

If it were to be a blocky avatar or any other bundle (for instance, Robloxian 2.0), it works perfectly fine:

Yikes. I am not seeing that on my end. I will ask around and see if anyone can repro.

1 Like

I will see in a few minutes if this bug is occurring on other devices as well as in other accounts, if this can help too

I have reverted the flag.
So now the original problem will be back but the no-pose problem should be fixed.
Can you confirm?
Also, can you provide details on what platform/device you were using when you saw no-pose behavior? Like Mac Client, iOS, Android, etc?

1 Like

The no-pose behavior is now gone, however, unfortunately, the problem returns to the point where it infinitely loads, and the avatar breaks.

The device that I used and encountered the problem was iOS, iPhone XR

@CycloneUprising was there anyone able to reproduce the issue?

Furthermore, it seems that the problem occurs primarily for new Roblox bundles that contain Facial Animations and Dynamics Heads.

We have one engineer who could repro.
She is remote.
We tried peer programming to sort it out but it was time consuming. She is in the office today so we hope to sort it out today, get in a fix.

Sorry for the back and forth and thanks for your patience and debugging tips.

1 Like

@CycloneUprising May she is invited to the forum and return with an update regarding the bug? As she was the only that could reproduce, it may be good to showcase photos and/or videos if everything is OK!:bulb:

It is totally fine as there are tons of things you all do behind the scenes, it requires focusing on the primary cases. My replies are always a bit of a reminder, haha! :smile:

Thank you for your message @CycloneUprising! :pray:t2:

OK. I believe we figured out the problem and fixed it.
(Details: a mood asset was owned by a “Roblox employee only” group, meaning it’d cause issues for anyone not in that group. I and most people on my team are in that group → we never noticed issues. The assets ownership has been updated).
I just enabled the fflag for the original issue.

So at this point everything should be working:

  • Original issue of corrupted mesh after posing in PPE should be resolved.
  • Should be no issues with posing not happening or being stuck with “loading” circle while posing.

Please test and confirm if you have a moment.


Heya, @CycloneUprising!

Checked right now utilizing one of the newest bundles of Roblox called “Billie” (whatever bundle with Facial Expressions experiences the same thing, just so you know) without any Layered Clothing and it seemed to work:

One of the things I have figured during the test is that while it tries to be in the pose based on the thumbnail, the body parts pass through themselves or even have it flipped:

Likewise, these problems must be related to the creation of the characters and the problem we have been discussing has come to an end. Thank you for everything and for the help of the other Roblox engineer… Now, let’s celebrate! :clinking_glasses:

So to make sure I understand:
The issues you mention/screenshot above are separate/new issues. The original issue is now fixed, with no additional/new issues introduced, correct?

1 Like

Yes, correct! The screenshots as mentioned are other issues I am going to report and the original is fixed! :partying_face: