Roblox wont open and cannot uninstall

Roblox and Roblox studio won’t open, It was working fine 1 hour ago and I tried everything possible to make it work, but it seems like when opening either Roblox or Roblox studio the process stays there still without opening Roblox, I tried uninstalling it, but it won’t work it does the same thing, opening the process without the actual software, Please help me out with this because I have commissions to complete! Thanks in advance!


this is most likely because there are services running in the background that prevent it from opening because it thinks it is already open. to end the services, first look in task manager (ctrl + shift + esc) and if there is a roblox process in the background processes or whatever then click it and press end. if there aren’t any roblox processes in task manager, then press WINDOWS + R to open “run” and type in services.msc and press enter. then search for anything with Roblox in the name. if the status says running, then click it and select “stop the service” (click stop), then reboot your pc and it should be good to go. just leave a message if it still isn’t working!


Never mind I rebooted my router and Roblox worked, I don’t know what the hell was going on because I had other applications not working at all