Roblox won't run on Windows 11 Home 22H2

Alright, so I just got a brand new PC and tried running Roblox. When I try to play a game, it goes through the starting process but doesn’t load me into the game or even into the loading screen.

I’ve tried deleting all Roblox files and reinstalling it and that won’t work. I’m running Windows 11 Home 22H2, I have no available windows updates. The Microsoft Store version crashes instantly, it doesn’t even try to load.

Here’s the log file:

2024-07-06T22:50:37.293Z
2024-07-06T22:50:37.034Z,0.034279,0ff8,6,Info [FLog::DesktopInstaller] The installer reporter is initialized
2024-07-06T22:50:37.034Z,0.034586,0ff8,6,Info [FLog::DesktopInstaller] Reporting Installer Start
2024-07-06T22:50:37.263Z,0.263023,1104,6,Info [FLog::DesktopInstaller] Start the Installer thread
2024-07-06T22:50:37.302Z,0.302378,1104,6,Info [FLog::DesktopInstaller] The installer will run InstallNormal
2024-07-06T22:50:37.302Z,0.302482,1104,6,Info [FLog::DesktopInstaller] Fetch flag info
2024-07-06T22:50:37.405Z,0.405207,1104,6,Info [FLog::DesktopInstaller] Installer runs as standard user
2024-07-06T22:50:37.440Z,0.440524,1104,6,Info [FLog::DesktopInstaller] Looking for open processes matching the filename RobloxPlayerBeta.exe
2024-07-06T22:50:37.448Z,0.448918,1104,6,Info [FLog::DesktopInstaller] Found 1 processes matching the filename RobloxPlayerBeta.exe
2024-07-06T22:50:37.449Z,0.449270,1104,6,Info [FLog::DesktopInstaller] Fetch version info
2024-07-06T22:50:37.495Z,0.495329,1104,6,Info [FLog::DesktopInstaller] Current version: 0.631.1.6310472 and version GUID: version-1088f3c8e4a44cc7
2024-07-06T22:50:37.623Z,0.623456,1104,6,Info [FLog::DesktopInstaller] The system has compatible WebView2 runtime, skip deployment of the WebView2 installer
2024-07-06T22:50:37.669Z,0.669648,1104,6,Info [FLog::DesktopInstaller] Create installation folders
2024-07-06T22:50:37.706Z,0.706720,1104,6,Warning [FLog::DesktopInstaller] The registered handler C:\Users\lapet\AppData\Local\Roblox\Versions\RobloxStudioInstaller.exe for roblox-studio does not exist
2024-07-06T22:50:37.706Z,0.706771,1104,6,Info [FLog::DesktopInstaller] Client does not have a valid roblox-studio handler
2024-07-06T22:50:38.071Z,1.071141,1104,6,Info [FLog::DesktopInstaller] Create launcher shortcuts
2024-07-06T22:50:38.341Z,1.341993,1104,6,Info [FLog::DesktopInstaller] Download and install files
2024-07-06T22:51:00.307Z,23.307922,1104,6,Info [FLog::DesktopInstaller] Create launcher shortcuts
2024-07-06T22:51:00.807Z,23.807980,1104,6,Info [FLog::DesktopInstaller] Register environment info
2024-07-06T22:51:20.854Z,43.854511,1104,6,Critical [FLog::DesktopInstaller] failed to start client App: "C:\Users\lapet\AppData\Local\Roblox\Versions\version-1088f3c8e4a44cc7\RobloxPlayerBeta.exe" -app -isInstallerLaunch, erorr code: 0, wait result: 258
2024-07-06T22:51:20.858Z,43.858742,1104,6,Info [FLog::DesktopInstaller] Reporting Installer Success
2024-07-06T22:51:20.858Z,43.858833,1104,6,Info [FLog::DesktopInstaller] Installer thread completed successfully
2024-07-06T22:51:20.859Z,43.859524,0ff8,6,Info [FLog::DesktopInstaller] Shut down InfluxPointsReporter with timeout 200 milliseconds

Any help much appreciated!
Thank you in advance.

1 Like

someone more knowledgeable than me may be able to help more but if no one does, here is the response I got from asking ChatGPT about it

Troubleshooting Steps:

  1. Check for Running Instances:
  • Make sure there are no running instances of Roblox. Open Task Manager and end any processes related to Roblox (RobloxPlayerBeta.exe, RobloxStudio.exe, etc.).
  1. Reinstall Roblox:
  • Uninstall Roblox completely:
    • Go to Control Panel > Programs > Programs and Features, find Roblox, and uninstall it.
  • Delete any remaining Roblox folders:
    • Delete the folder C:\Users\[YourUsername]\AppData\Local\Roblox.
  • Re-download the Roblox installer from the official website and run it again.
  1. Administrator Privileges:
  • Run the installer with administrator privileges. Right-click the installer and select “Run as administrator.”
  1. Compatibility Mode:
  • Try running the installer in compatibility mode for an earlier version of Windows. Right-click the installer, select “Properties,” go to the “Compatibility” tab, and check “Run this program in compatibility mode for:” and select an earlier version of Windows.
  1. Check Network Connection:
  • Ensure that your network connection is stable and that there are no firewall or antivirus settings blocking the installation or the running of Roblox.
  1. Update Windows and Drivers:
  • Ensure that Windows and all device drivers are up-to-date.
1 Like

None of that worked. My windows and drivers are all up to date as well.

Edit: My wifi is stable, I’m running ethernet providing me 1000mbps down and 900mbps up.

1 Like

It looks like it never installed the roblox studio package to where it was supposed to be I think it could be due to privileges a.k.a run as administrator the studio installer.
The registered handler C:\Users\lapet\AppData\Local\Roblox\Versions\RobloxStudioInstaller.exe for roblox-studio does not exist

Does the ROBLOX player work for you?
When you uninstall ROBLOX make sure to delete all files related to ROBLOX studio settings.

1 Like

So… run the Roblox Player installer as Administrator?

My Studio works to my surprise. It’s the Player that doesn’t work.

3 Likes

I ran both installers as Administrator and it still doesn’t work.

Edit: My studio is now no longer working.

1 Like

you said you deleted them and all related files, how did you do that?

1 Like

I went into both Appdata and Program Files x86 and deleted the “Roblox” folder.

ok try going to settings
image

and then going to the Control panel > Programs >Programs and Features > Uninstall or change a program

image

image

I don’t think this will work, but you can try sfc /scannow or troubleshoot over Microsoft store with

Get-AppxPackage -allusers *WindowsStore* | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
1 Like

I meant that and then deleting the Roblox folders.

have you tried…

Using another Account

Using another device

Using a VPN

Going back to a previous version of Windows

sfc /scannow worked. I can’t believe I didn’t think of that. Thanks.

1 Like

What a miracle, sfc scan did something

I have the same problem (new laptop, basically the same logs), but sfc /scannow isn’t working

Did you run the window as an admin?

Yeah, forgot to mention, but it just fixed itself the next day for no reason