Roblox/Roblox Studio not launching but running as a background task

Basically whenever I try to open Roblox or Roblox Studio it just goes to the background task and uses all of my CPU.(I tried reinstalling Roblox entirely,Restarted my PC,cleaned temp files,updated my graphics cards and tried running as an administrator it still gave same result)

It happens whenever I try to open anything Roblox or Roblox Studio
I Use Windows 10 with Intel(R) Core™ i5-8300H CPU @ 2.30GHz,32.0 GB,Intel(R) UHD Graphics 630,NVIDIA GeForce GTX 1050 Ti

Expected behavior

It should either when opening Roblox just open the Roblox home application and when opening Roblox Studio open the Roblox Studio home application

A private message is associated with this bug report


Hey @adamik98 - thanks for the report. Sending this over to the studio team.


It seems something changed recently. Roblox ends up opening after around 10 minutes but it’s like 75 % it will just show Roblox crashed window and like 25 % opening roblox app and crash window with studio its around 7-8 minutes and nothing is wrong everything is working perfectly fine.

1 Like

Hi - can you send us a log from Studio on the latest version? Would be interested to see what’s happening for 7–8 minutes before it shows up. Generally crashing that early indicates some OS incompatibility like a driver issue.

1 Like

I have edited the private message that includes the log and recent thing i found out about Roblox crash thing


Hi - I believe this is related to some other issues we’re having with Oculus. From the screen shot I see its installed. Can you disable/disconnect/uninstall and see if that fixes your issue?

1 Like

Hi all - we believe we have patched this issue. Can you please retry and let us know? (Ensure you have restarted/have latest version).

The issue got worse by casually being kicked out of the place roughly a minute after joining.

Sorry, are you saying this is the same issue? Is Studio or player now starting or still hanging in the background on start? All interference with/because of Oculus should be resolved.

Happens to me 50% of the time. On any other startup besides the first, studio wont load, or take a very long time to load.

What does “besides the first” mean? First after install? First instance running on the machine? Can you submit two logs, one from the first instance starting up, and then another from a second instance that takes much longer (or never starts)?

When I first start up studio, the very first time after turning on my computer, it opens fine.

It seems studio has been opening faster though.

the issue is the same on roblox player however on studio it just sometimes gets to the point i will get kicked out of the place after a minute or so