Rope Physics Issues

Hello there,

I am currently trying to move custom player rigs using rupes connected to a helicopter using the Blizzard engine.

However, instead of lifting the player connected to the helicopter up, the helicopter just spins around the player and the player remains stationary.

I would look forward to any help in solving this,
thank you

Does it act like the player is the anchor point?

Yep it does.

Although I made sure all parts inside the player’s character get unanchored and massless.

Have you tried switching Part0 and Part1 of the rope?

1 Like

Let me try that real quick. I will keep you updated.

Well, now it kinda worked, the character lifted up with the initial pull, but then pulled the helicopter back down. So still not the solution

1 Like

You can still move the character right?

1 Like

Well, it’s a dinosaur custom character.

In theory, it can move, yes, but a requirement for the rope to connect is the dinosaur being tranquillised.

Are you sure that the dinosaur isn’t anchored? Are there any welds on the dinosaur that are connected to an anchored part?

Yep. I tested it and made it so the dinosaur does not need to be tranquillised the dinosaur, still an issue then.

Have you also checked this out?

I mean, I think if that would be the case, the dinosaur would be unable to move, correct?

Actually yeah, I guess that’s true.

Well I am stumped, not sure why the dinosaur is acting as an anchor point.

Probably blizzard acting as helicopter system.