Rope Winch not updating on server, only on client

I have a Winch using the Rope constraint, the target is set and this works perfectly fine on the client.

However, the winch doesn’t change the rope’s length on the server side like it does on the client, even though the WinchTarget values are the same on both the client and server.

All code that adjusts the WinchTarget is done server side via a RemoteEvent, so this isn’t a filtering issue.

Server side:

Client side:


It might be a network ownership issue if the constraint is tied to an unanchored part such as the airplane. How are you handling the ownership currently, maybe try to set the ownership back to the client right after the weld to the winch is made (im assuming a weld is made to the winch at some point via script?)?

I tried setting the unanchored parts’ network owner to nil and still the same issue, same goes for setting the network owner to the client.

1 Like

I am having a similar issue. When I set WinchTarget on the server side, the rope’s length changes only for the player who is the NetworkOwner of the assembly that the rope belongs to. The length change does not replicate to other clients, even though the WinchTarget property itself was set on the server side and is replicated to everyone.

In my opinion this is a Roblox bug.