Ropeconstraints Problem in a tool and anchored part

Hello, I am trying to achieve a taser just like New Haven County, I don’t want to copy on everything, but I want do it differently.

In the first link the tool is glitching, its been worst than that.
In the second video when ever you go up and down, it makes you fall over, trip, sometimes even glitches under the map.

I have tried welding a part to the tool with a attachment.
I have looked on Devforum and google for any solutions and I have not found any.

What the taser should be like:

If you would like the script/lua please send me your discord so I can add you, the reason for this is because is because I worked hard on this script and a lot of people want it.

How I did this:

  • instanced a anchored brick, transparency 1, cancollied false, position = tased persons torso.
  • instances a attachment, parent = anchored brick
  • instanced a Ropeconstraint, parent = attachment
  • In the tool there’s a atachment I made already
  • then I connected the Taser attachment and the Attachment with the Ropeconstraint.

What I’m asking for is a possible solution. Or a fix for either problem.


  • UhYouFoundRBLX

can you add me (r0b#3887) i’ve been looking for a taser like this

I’m interested with this. fork#4283