Rotating a rig part in the animation editor rotates everything else but the part

  1. What do you want to achieve? Keep it simple and clear!

So basically I’m trying to animate my own viewmodel rig, but whenever i try rotating the arm or gun it rotates the rest of the rig instead of rotating the arm/gun.

  1. What is the issue? Include screenshots / videos if possible!
  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

Tried swapping Part1 and Part0, using different weld plugins, moving joint positions, all to no avail.

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

I used the Moon Animator Plugin and I used its easy weld feature.

2 Likes

I have the same or at least a similar problem, and it’s high priority for me.
At the moment I can’t help you much other than say “you are not alone” :sweat_smile:
I’ll let you know when I get further :+1:
(Btw, I tried different things with welds, motor6Ds, model strucutre etc and I used the the standard anmation editor - also without success)

2 Likes

Sorry for the somewhat delayed reply, my topic was created a while ago and I never bothered to update the thread when i finally found the solution haha.

Anyways, what I did to fix the issue was enable the “Massless” property in the meshparts I tried animating. Thats it.

Tell me if this method works for you. If it doesn’t, you can try this workaround I came up with:

  • Create a regular part and scale it up a lot.
  • Create a SpecialMesh and have it parented to the part.
  • Paste the MeshID in the MeshID property of the specialmesh. Your part should now be representative of said MeshID.
  • Scale down the part so it’s not abnormally huge
3 Likes

Oh nice :smiley: Thanks!
I just managed to make it work. I don’t really know how, since I am certain I already tried every possible option.

But your solution for the MeshPart might become very useful, since I initially worked with MeshParts and switched to Parts when I had trouble.
Thanks again :smiley:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.