Run animation doesnt play for other characters

so basically, im currently working on a set of custom animations (run, jump, walk, etcetera) and they all work like they should be… however, for some reason the walk/run animation is the only one that doesnt play for other characters, the jump animation works fine, much like the idle animation, which doesnt happen in studio when i set up a server… the animations are all handled by the same script too so i am absolutely dumbfounded to what could be the issue here (not gonna provide my script since its literally just the standard roblox animation script)

1 Like

Are you saying that all you have done is edited the default animation script with your own animations?

Animations have some strange replication behavior that I’ve run into, and reuploading them usually fixes it. For me, it’s usually one of the following:

  • Check that the priority value of the animation editor is set to the same priority value that the animation is played as. If you try to play an animation with Action priority on the client, but the actual animation is uploaded with Core priority, you may run into weird replication problems.

  • If the animation is meant to be looped, check that the animation you uploaded has Looped checked in the animation editor. Otherwise, the animation will only play once on the server, but if you set it to looped in a client-side script, it will keep looping in the client. Your run animation is most likely not looped in the animation editor.

This is because of how animations are replicated. If you change any properties of an AnimationTrack on the client (in a LocalScript), such as whether Looped is enabled, it will not replicate to the server. The animation will only be played to other clients with the exact same properties that it has in the animation editor.

For example: If you upload an animation with looping turned off, and then you set looping to true on the client and play the animation, the client will see the looped animation while the server will see the unlooped animation (how it was uploaded).

1 Like

This might be a stretch, but if you’re using the beta animation editor on an R6 rig and uploading it from there, the animation is corrupted and won’t play (you need to upload it using the current editor). The issue is probably simpler than that, but I’m going to mention this just in case.

so, a quick update, ive reuploaded the animation and it still does not load properly for other clients, they just default to the humanoid stance, which is very odd

@Shardwielder i know how to handle animations, but thanks anyways i guess? my problem isnt missing loops or anything of the sorts

@sz_s im not using r6 rigs either, but yeah those are pretty whacky

in summary, i have absolutely no clue whatsoever why my animation wont play at all for other clients…

Very late to the party here, but I ran across this thread after having exactly the same issues as reported by the OP: I have custom animations for several of the normal movements. They all work perfectly for me in studio, and worked well for me in the published version, but for some reason only run/walk would not work…for some players only.

Turns out it was a simple fix - I didn’t have a wait built into my script to change the default animations, and for some reason the first one or two listed were not loading for some players. Adding a short wait corrected the issue - I’m guessing a WaitForChild fix would be more appropriate.

I’ve since run into some weird animation replication behavior myself, you might want to check if this is the issue: Replacing default animation only plays for client

For future reference for people on this thread, also please see this: Animations Replicate Inconsistently

We really need a unified thread for strange animation stuff.