Sanitized ID. How do I fix this?

Hello, I have seen many topics on this and spent lots of time trying to get a simple animation to play but all of the solutions I have tried never worked. When I run my animation in the game, it says, Failed to load animation - sanitized ID: rbxassetid://17353845468 (The game is under a group and I put in 2 animations 1 under the groups name and 1 under mine but both of them had this error). Any help?

local inRadius = false
local radius = 15
local objectPosition =, 3.764, 63.418) or game.Workspace.ForestHelmetShop.Helmet.Position
local UserInputService = game:GetService("UserInputService")
local open1 = script.Parent.open1
local animation = game.Workspace:WaitForChild("blackSmithPlace"):WaitForChild("Hammer"):WaitForChild("AnimationController"):WaitForChild("Animation")
local loader = game.Workspace:WaitForChild("blackSmithPlace"):WaitForChild("Hammer"):WaitForChild("AnimationController")

	if inRadius == true then
		if script.Parent.Visible == true then
			local Cam = game.Workspace.CurrentCamera
			local CameraObject = game.Workspace.blackSmithPlace.rollCam
			script.Parent.Parent.Active = false
			script.Parent.Visible = false
			script.Parent.Parent.HelmetFrame.Visible = false
			Cam.CFrame = CameraObject.CFrame
			game.Players.LocalPlayer.Character:WaitForChild("Humanoid").WalkSpeed = 0
			Cam.CameraType = Enum.CameraType.Scriptable

			--params: helmetBoxNumb
			--play anim
			local load = loader:LoadAnimation(animation)

1 Like

I had this bug once, all i really did was shut down my computer and the next day the animations were working. You should also both animations under the groups name, if not, you’ll have to grant the group access to the animation.

I tried restarting it didnt work and theres only 1 animation i just tested it with 2 one was under my name and the other under the groups


15th time, this is either moderation or a bug that’s been around way too long for people to be making posts before searching.

Were you able to find a solution for the sanitized id error?

Sadly no I am still watching youtube videos and other posts but none of them work.