Screen-space ambient occlusion does not appear in Studio or Player

The screen-space ambient occlusion effect doesn’t seem to appear at all. It happens both in Studio and in the Player. SSAO stopped appearing when Roblox updated to version 429 and the Atmosphere class was added.

I’m led to believe some sort of rendering change under the hood led to this and other things breaking, and not the addition of Atmosphere.



The small shadow under the DiamondPlate part is just a shadow cast from the sun and isn’t actually SSAO, screenshot was taken in Arsenal

To reproduce, load up a place on Studio or play a game on the website and turn the graphics up to max.

System Specs



I’ve noticed SSAO (the shadow effect when things are close to each other and on corners) doesn’t work anymore in the current version on maximum graphical settings. It apparently happens only ingame, since I booted up Roblox Studio, activated terrain decoration and the grass still had the strange noisy effect caused by SSAO.

Studio screenshot:

You can reproduce this by going in any game and putting on max graphical settings.
If this has to do with driver things or whatever in some way, here are my specs:
RTX 2070
Intel Core i7 8700

EDIT: the effect seems to not work on Studio either now.