Script doesn't play audio

The script I have doesn’t seem to be playing the sound…


local Remotes = game.ReplicatedStorage.Remotes
--local AudioFolder = game.Workspace.Narration

--local debounce = false
--local audioIsPlaying = false

	if hit.Parent:FindFirstChild("Humanoid") then
		local player = game.Players:GetPlayerFromCharacter(hit.Parent)
		if player then	


local Player = game:GetService("Players")
local SoundService = game:GetService("SoundService")
local Subtitle = Player:WaitForChild("PlayerGui"):WaitForChild("Subtitles"):WaitForChild("Subtitle")
local SoundFolder = game.Workspace.Narration
local Remotes = game.ReplicatedStorage.Remotes

--//Intro Narration
	local VoiceIntro1 = SoundFolder.Intro.voice_intro_1_00
	--subtitle.Text = "Text"

–Sound Properties

–SoundFile Location
It’s in a folder that’s in Workspace

–Remote Location

–LocalScript Location

–Script Location
It’s in a folder that’s in Workspace

1 Like

Have you tried playing the sound directly?
Example: SoundService.VoiceIntro1:Play()

If you press the green play button under “Preview” does it play audio?

Why is RollOffMinDistance so high?

yes, it does play the audio when I press the button

that didn’t fix the issue, sadly.

Okay, does it print the “Test”?

yes, it does

Can you try putting a different sound from the toolbox in the sounds SoundId spot and see if it plays anything?

Can you try lowering the RollOffMinDistance?

tried that before, didn’t work

that also didn’t work, not sure what’s wrong

any errors inside the script? maybe checking the id if its correct

the ID is indeed correct, I checked it

maybe at the local script use print to check if it played or not
also how about using sound:Play() instead?

Is your Roblox volume up when you test it (via the in-game settings menu)? I don’t see any problems. If you have any errors regarding this make sure to send those too.

yep, I checked that, I maximised my computer volume also

Can you send a rbxl THAT ONLY CONSISTS of the script that fires the remote, the sound and the local scirpt?

Alright, I will send an rbxl file.

I think the problem might be the touch script they server are communicating well