[Script Editor Folds Beta] Studio crashes when typing special symbols (cyrillic, accents, emoji, etc.)

After I reinstalled Windows 10, when I write the Cyrillic alphabet, the studio just crashes. I asked my friend about this, he does not have such a mistake (but i have). In my opinion, this error occurs due to incorrect definition of syntax color, as there seems to be no such problem with comments.

Logs
1581773571.02940,17cc,6 

Command line:
C:\Users\Shaehl\AppData\Local\Roblox\Versions\version-768bc682fe234208\RobloxStudioBeta.exe -d


1581773571.02940,17cc,6 Finding AppSettings.xml
1581773571.02940,17cc,6 Opening AppSettings.xml
1581773571.02940,17cc,6 Parsing AppSettings.xml
1581773571.02940,17cc,6 Looking for 'Settings' element in AppSettings.xml
1581773571.03040,17cc,6 Looking for 'ContentFolder' element in AppSettings.xml
1581773571.03040,17cc,6 Looking for 'BaseUrl' element in AppSettings.xml
1581773571.03040,17cc,6 BaseUrl loaded from 'AppSettings.Xml'
1581773571.03040,17cc,6 Looking for 'IsScriptAssetUploadEnabled' element in AppSettings.xml
1581773571.03140,17cc,6 Looking for 'IsAnimationAssetUploadEnabled' element in AppSettings.xml
1581773571.03140,17cc,6 Looking for 'IsImageModelAssetUploadEnabled' element in AppSettings.xml
1581773571.03140,17cc,6 Looking for 'CrashMenu' element in AppSettings.xml
1581773571.03140,17cc,6 BaseUrl: https://www.roblox.com
1581773571.03140,17cc,6 fetchClientSettingDataViaHttps
1581773571.31456,17cc,6 LoadClientSettingsFromLocal group: "ClientAppSettings"
1581773571.31456,17cc,6 LoadClientSettingsFromLocal group: "StudioAppSettings"
1581773571.31456,17cc,6 Studio Version: "0.419.0.381237"
1581773571.31556,17cc,6 CrashReporter Start
1581773571.31556,1ac4,6 WatcherThread Started
1581773571.80929,17cc,6 Uploading 1 crashes to Backtrace
1581773571.80929,17cc,6 Uploading C:\Users\Shaehl\AppData\Local\Roblox\logs\log_DDB36 0, 419, 0, 381237.RobloxStudio.dmp to https://upload.crashes.rbxinfra.com/post?format=minidump&token=8608fce9cad86072eee36b7d1d9dc56d68101a6b1f783c7bf568d80972ee1837&RbxCrashReason=&RbxCrashMessage=&PlaceId=95206881&PlayerId=1003129349&DatacenterId=0&ServerIp=&IsVIPDeveloper=false&AppVersion=0%2E419%2E0%2E381237&PlayTime=45&UsedMemory=594067456&BaseUrl=www%2Eroblox%2Ecom&BetaFeatures=EnableNewScriptFoldStateBeta&InstalledEnabledPlugins=144950355&IsTainted=false&UniqueId=1305368595558750585&Is64Bit=true&GPU=NVIDIA%20GeForce%20GTX%201060%203GB&GPUDriver=nvldumdx%2Edll%2026%2E21%2E14%2E3200&AudioDeviceName=%D0%94%D0%B8%D0%BD%D0%B0%D0%BC%D0%B8%D0%BA%D0%B8%20%28Realtek%28R%29%20Audio%29&AudioSystemRate=48000&AudioSpeakerMode=3&AudioSpeakerModeChannels=2&AudioPreferredSoundDeviceIndex=0
1581773591.81480,17cc,6 Crash id: b7b10000-3262-f103-0000-000000000000
1581773591.81480,17cc,6 Uploading C:\Users\Shaehl\AppData\Local\Roblox\logs\log_DDB36_1.txt to https://upload.crashes.rbxinfra.com/post?format=minidump&token=8608fce9cad86072eee36b7d1d9dc56d68101a6b1f783c7bf568d80972ee1837&object=b7b10000%2D3262%2Df103%2D0000%2D000000000000&attachment_name=log%5FDDB36%5F1%2Etxt
1581773592.25776,17cc,6 Exception when uploading log files(s): HTTP 500 (Internal Server Error)

My system is Windows 10 (1909).

This happens when the “Script Editor Folds Beta” is enabled in Studio Beta Features.

Dump file: sha3hl & AtomicOperation DM link

7 Likes

hello, hello, whenever i press the alt. german letters “ä, ö, ü” during scripting it crashes studio.
(example below)

I have the script editor folds behaviour beta enabled

2 Likes

I have this exact issue aswell. It’s super annoying while trying to type these “” quotation marks and accidentally typing ‘ë’ or something cause am on international keyboard

2 Likes

Whenever I open a script and type normally it works fine, sometimes when I hit “ö”, “ä” or “å” by accident it crashes. It does that ALL the time, no matter what computer, game, script or place it is. Super weird, not sure what the problem is but it could be something with my font. Though I tested other fonts and the same happend. This has been happening a couple weeks, I don’t know exactly.

I have Windows language set to Swedish, and so is my keyboard layout.

Specs:
Windows 10 1909 (18363.657)
Intel Core i5-7400
64-bit

2 Likes

Hello there!

Lately, I’ve been experiencing a very annoying bug on Studio, which always causes Studio to crash.
It’s very easy to recreate, but it depends on your keyboard layout.

If you use a European Spanish keyboard, you should have the ç key, commonly on top of the enter key.

That’s the most annoying part. It’s close to enter, meaning it’s very easy to click accidentally.

All you have to do to crash Studio is open up a script and press the ç key.
Studio will then freeze for one or two seconds and show a message saying “An unexpected error has occurred and Roblox needs to quit.”

I believe this is a very important and critical bug for Spanish developers that should get a fix soon.

I’m not sure about when this started. I don’t think screenshots are very descriptive either. But here’s the message. You probably already know what I meant anyway.image

Here’s the log, it might help if you don’t have a Spanish keyboard and can’t reproduce the glitch:
log_84A10_1.txt (6.9 KB)

Thank you.

EDIT: I had created a topic but a mod found this one and it was moved here. Need a fix! The Ç key is just next to the enter key and I accidentally press it very often!

1 Like

Problems occur when you copy-paste these letters š,đ,č,ć,ž or in my scenario when I type them in. It is impossible to work, my studio crashes around 20 times in 8 hours of work.

1 Like

It’s pretty straightforward. Every time I paste an emoji directly in the script editor (not in a string), studio crashes. I don’t do this often, but when I do:

local foo = "🙃"
2 Likes

This should be resolved. Let us know if you are still experiencing this issue!

2 Likes