Script erroring; won't tell me any details other than what script errored


I have a script that is only working in studio playtest. When I run my game in regular roblox, it just gives this cryptic error;

doesn’t tell me what the error is, what line or anything. The script doesn’t even run because it’d print “Hi” if it did;

Note that the script works flawlessly in playtest so I doubt it’s an error with the script itself.

Sorry, I’m not sure why exactly it’s doing that, but if Collaborative Editing/Team Create is on, it might not show the changes in Roblox until you commit the “Draft”.


Something like this happened to me a while ago, and I was so confused because I didn’t know about the “Drafts” thing. Also if the script is in ReplicatedFirst, you could temporarily move it to StarterPlayerScripts or something to determine the issue.

Could you give me more information about the script, other scripts that are enabled, it’s name, and where it’s located?

i ‘figured it out’. the script instance was broken somehow? i simply created a new script instance and copied the EXACT same source code over and it worked fine.

this bug and a strange bug i had a couple hours ago (also posted to this topic) really shows how buggy studio is atm

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.