Hello, when I first began to code I was learning basics such as functions and never really noticed that in many teaching videos, developers organized their code into sections such as:
Variables,
Functions,
Main lines.
I was watching videos on modules and noticed in the video they had different capitalization such as:
transferInfo (name), in comparison to TransferInfo. I was just curious as to if this had an overall goal, was simply for looks, or had some kind of meaning.
Naming convention (programming). It helps with readability and clearly identifying what you’re working with based on the casing of a variable. Roblox does this too and you see it when you work with engine APIs - most of them are in PascalCase.
A lot of naming conventions used on Roblox by developers, at least that I’m aware of, follow some degree of the style guide set by Roblox internally - Roblox style guide.