Script not working?

Hey, there I am making a game that requires the camera and lerp thorugh a bunch of positions. The thing I hate is that (I don’t know if it is a studio bug or not) the script I use doesn’t even save when I click the game. It keeps on printing hello world.

This is what I’ve found happens when you clone the script:

Please help this is really annoying. (I am in team create if that helps.)

1 Like

go to drafts in the view page at the top.

I don’t know what you are talking about, can you please explain?

click view at the top then click drafts. It should be there.

Is Team Create enabled? If so, you need to commit your scripts.

It was, now that it is off the script doesn’t say hello world but it still doesn’t work?

I don’t know if I can see drafts…

Have you tried restarting studio and turning off team create (if it’s on).

So interestingly enough, your issues is that you’re trying to use a server script on a client camera.

Please use a local script inside one of the local script storages like StarterPlayer > StarterCharacterScripts with the following code

local Player = game:GetService("Players").LocalPlayer
local Character = Player.Character or Player.CharacterAdded:Wait()

workspace.CurrentCamera.CameraType = Enum.CameraType.Scritable

this should in turn change the Player’s actual camera to scriptable.

P.s drafts only show up if you have collaborative editing on.

1 Like