Script Working in Main Place, but not other Places

Hi everyone,
The title pretty much says it all. I’ve been able to successfully create a feature in my game, and upon overwriting another place, within my main group game so I could test it with the correct permissions, I’m getting errors thrown like such:

I have no way of being able to replicate these in my main game, as I am not getting these errors otherwise. The only difference is that the working game is the main game, and isn’t simply a place inside of an experience, and that the broken game is in a place inside of an experience. The errors are also replicated when I run the place in studio, despite there being no difference in game settings between the two. Any help would be appreciated.

It’s probably because the things in the Game are different, have you tried to Copy-Paste everything?

Nothing between the two games are different. I used the original testing game to overwrite the other Place, and even manually replaced any scripts that were different.

Could you show us the script?
It’s probably a problem there, have you tried to rewrite it in the Game? Like making a Script and Copy-Paste everything in?

Attached is where the error is being thrown from.

There is, however, virtually no reason that it’s an actual problem with the script considering it’s working in the other games.