Selection Box Display Issue

Encountering a bug with selection boxes not displaying beyond a very small distance. As you can see in the gif below, the two brick’s outlines are acting separately when I have both selected and not displaying past a few studs away.
Selection Boxes

This makes it very hard to make selections containing many separate objects. Hover Over effect still properly shows, this has only affected selections. Rejoining does not fix, and I have confirmed it with other developers as well.

18 Likes

I’ve been encountering this issue as well. Very frustrating to deal with.

I can confirm this issue happens to me as well, although it’s a bit longer of a distance than yours.

1 Like

Description -
In studio solo testing and editing mode selection box OBJECTS won’t show after 150 studs out. Studio part/model selection won’t show after 30 studs out. (All regardless of studio edit quality level and in game quality level.)

Selection Box Objects in Live Game: Doesn’t Show after 150 studs.
Selection Box Objects in Studio: Doesn’t show after 150 studs.
Part/Model Selection in Studio: Doesn’t show after 30 studs.

  • Places it happens - In live games, studio editing, and studio play mode.
  • When it started occurring - March 17th 2021 after the ROBLOX Client and Studio update.
  • How I view the bug - Studio and live game, putting a selection box and setting its adornee and walking away it disappears.
  • ROBLOX Studio Version* - 0.470.0.419147
  • Screenshots -

Studio part/model selections
Between 0 - 30 studs in:


30 Studs out:
Screen Shot 2021-03-18 at 9.32.42 AM

Studio selection box objects
Around 140 studs out:
Screen Shot 2021-03-18 at 9.34.07 AM
Around 150 - 160 studs out:
Screen Shot 2021-03-18 at 9.33.54 AM

Live game selection box objects
Roughly 130 studs out:
Screen Shot 2021-03-18 at 9.39.38 AM
150 studs out:
Screen Shot 2021-03-18 at 9.39.26 AM

Misc
I currently use selection boxes for letting players who use our games weapon to give them another visualization of them hitting there enemy by highlighting that character part that was hit with it. With this issue occurring right now you can’t even see the box from like 30 studs away regardless of ones graphics level.

2 Likes

I too can confirm this happening. My pc is a Windows 10, with the latest version of Studio.

Frustrating beyond belief when working on larger builds. Can’t really tell what is selected.

1 Like

This issues’ an absolute problem for distance selection on large-scale models. Hopefully, they fix it soon.

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

2 Likes

This should now be fixed once you restart Studio. The root cause was changes to shaders that were required for the UIStroke beta, which is now disabled.

6 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.