Selling a third-party limited through my roblox catalog using MPS not working?

I have created a catalog using AvatarService, however when trying to purchase a limited item through the game I get this error. When I test in studio i don’t get the error, instead I get Item Purchased added to inventory.

image < --The Error

I have allowed all the required services in the games security. I bought the same Item in another players catalog game and it worked perfectly. Does anyone know why my error is?

Looking foward to hearing from you devs.

I dont think you can buy limiteds ingame? Or it may be a issue with UGC limiteds

You are able too as this game does: Catalog Avatar Creator - Roblox

I see, Probably a issue with code then. Maybe paste your code for someone to help

				local id = item.Id

						local val2send = id
						mps:PromptPurchase(player, id)

I have the asset Id there, tried it through server that’s why there was an event. Now trying through client. Still same issue as before.

Does anyone have an idea why the issue is occurring?

Issue solved. The game had to be public.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.