Separate Non-VC Servers & VC Servers

So I am working on a game currently, where I have 2 games separated, but in Asset Manager. One being (Voice Chat Servers) & the other one just being the Non-VC server. However when I turn on the game settings for Voice Chat Servers for voice chat, it also enables it for the one in Non-VC.

Here’s an example video below best showing what I am trying to do.

The left side being Non-VC & the right side being VC.

1 Like

From Roblox documentation:

Disabling Chat with Spatial Voice Per Place

If you don’t want to enable chat with spatial voice for every place within your experience, you can disable it within specific places that would otherwise be voice-eligible through the EnableDefaultVoice property.

If you are currently setting Max Players to a value over 50 to disable voice in a place, it is recommended to use this property instead. This ensures that chat with spatial voice remains disabled when max user limit changes.

To disable chat with spatial voice for a place:

  1. In the Model tab of the menu bar, navigate to the Advanced section, then click the Service icon. The Insert Service dialog displays.

  2. Select VoiceChatService.

  3. In the Explorer window, select VoiceChatService.

  4. In the Properties window, disable the EnableDefaultVoice property.

  5. Restart your servers to ensure the change takes effect for all servers currently running your experience.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.