:SetCoreGuiEnabled() failed to disable Core Gui's

I want to disable all core GUI’s by using the StarterGui:SetCoreGuiEnabled() function, however, it seems to not work as intended.

As seen in this photo: (script is in ReplicatedFirst)
image

I have disabled the Core GUI’s via the function, but during playtesting, the Core GUI’s seems to still be enabled.

I would like to know what caused this and how could I solve this issue.

2 Likes

… put it as a localscript in startergui instead

I have tried that already. Which, did not work.

local coreCall do
	local MAX_RETRIES = 8

	local StarterGui = game:GetService('StarterGui')
	local RunService = game:GetService('RunService')

	function coreCall(method, ...)
		local result = {}
		for retries = 1, MAX_RETRIES do
			result = {pcall(StarterGui[method], StarterGui, ...)}
			if result[1] then
				break
			end
			RunService.Stepped:Wait()
		end
		return unpack(result)
	end
end

coreCall('SetCore', 'All', false)
1 Like

Is there any errors in output?

Also what core gui is still enabled?

Make this a LocalScript in StarterGui:

task.wait(0.001)

local StarterGui = game:GetService("StarterGui")
StarterGui:SetCoreGuiEnabled(Enum.CoreGuiType.All, false)

The problem is that this is an ongoing ROBLOX issue, which can’t usually be solved. ReplicatedFirst isn’t a solution, but rather a service that shouldn’t be used. Any SetCoreGuiEnabled scripts SHOULD be in StarterGui.

7 Likes