Setting the ScreenGui.Enabled property to false doesn’t un-render gui buttons, affecting scrolling

The Issue:
Since the 28th of September, users have been experiencing issues scrolling in our game. The issue begins occurring after opening a menu ( ScreenGui.Enable = true ), and closing it ( ScreenGui.Enabled = false ).

How it affects our implementation:

Figure A

From my investigations to create a repro, I found out that button-type instances (TextButton, ImageButton, etc). After they are initially rendered, disabling the ScreenGui seems to not fully un-render them, and the mouse is unable to zoom. In Figure A, which is a picture taken the repro place below, you would not be able to use mouse scrolling in the white square area (TextButton) even after disabling the ScreenGui.

The repro simply contains two ScreenGui (SubjectA and SubjectB). SubjectA contains a TextButton that when pressed toggles the enabled property on SubjectB , which contains a large TextButton in it.

The bug does not seem to occur in Roblox Studio. However, in an actual game (Roblox Player), it would happen 100% of the time. Follow the steps below to reproduce.

  1. Download the repro.
    repro.rbxm (4.3 KB)
  2. Create a new place, insert the repro in StarterGui. You should get two ScreenGui (SubjectA and SubjectB).
  3. Publish the game and play in the Roblox Player.
  4. Click the button from SubjectA that Enable and Disable SubjectB. Notice that you can’t use your mouse wheel to perform zooming anymore where the TextButton from SubjectB is located.

I hope this was clear and a solution can be found soon.

1 Like

Thanks for the report. Fix will be out next week.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.