Severe Animation Editor bugs related to IK mode


#1

The animation editor is personally unusable for me right now. As you can see from the following screenshot the UI is severely bugged. The bug happens 100% of the time, currently on a Windows machine. Happens to all places.

(I should mention I’m on Dark theme for studio.)

When Inverse Kinematics is enabled the move tool behaves like so:

The white broken UI appears after closing the animation editor once (while having IK enabled), and re-opening it. It then looks like this:


System Specs:

image
image
image

To fix this I currently have to delete all Studio related files and reinstall.


#2

The editor is very buggy for me, also. The IK is what causes me most of the problems, resulting in console errors that prevent the use of the editor.


#3

[UPDATE]: Another gif of the issue, as you can see most of the body parts can’t even be selected. IK is not enabled. I restarted studio and opened a place, and this happened.

Quite unfortunate as I was in the middle of a commission that I’m not able to do anymore.


#4

Hey @LordHammy, thanks for bringing this to our attention. We believe your first issue has to do with this:

Latest Physics changes broke Prison Royale

Can you try setting AutoJointsMode property on Workspace to LegacyImplicit and see if that gets rid of the white UI and crash after opening the editor again while IK was enabled.

We will need to look further into your updated issue. Could you possibly provide me with the place file where things have broken?

Thanks


Animation Editor Bug for Rthro
#5

Hey, thanks for the quick response.

Your instruction to set AutoJointsMode to LegacyImplicit seems to have fixed the issue for me, and does not crash the Animation Editor, or cause any unexpected behaviour.

Here is a default Baseplate place where I’ve just tested it:
AnimationEditor_Repro.rbxl (21.5 KB)

Steps to Reproduce:

  • Change AutoJointsMode to LegacyImplicit
    • Open the Animation Editor Plugin, select the Dummy and turn on IK
    • Close the Animation Editor and re-open, it should be behaving as expected.
  • Change AutoJointsMode to Default
    • Open the Animation Editor Plugin, select the Dummy and turn on IK
    • Close the Animation Editor and re-open, the UI should be white, and when you attempt to close the editor, it should now be having issues outlined in the main thread.

(Note you’ll be stuck with the white UI/issues after this, and the only way I’ve found to fix this is to delete Roblox files from AppData and reinstall.)

[EDIT]: Another bug with the ‘fixed’ Animation Editor, happens when IK is enabled.


#6

Thank you! Also note, this fix of changing the AutoJointMode is temporary. Come February, Explicit will be the only mode available. I will be working on a fix to make sure the Animation Editor plays nice with the updated Physics changes and hopefully try to get it out before that happens.


#7

Thanks a lot for the help - even if it’s a temporary fix, I can now get along with my work.

Appreciate it!


#8

I’m not sure where I was actually supposed to post this but here is an attempt at posting it in the right place.

NOTE: I’m unaware if its any other rig types but Rthro is the one I have happen to experience.

The Bug:

Inverse Kinematic Joints
Alright so I decided to play with Rthro and I’m making animations, first thing I noticed was that there is a new animation editor update and started playing with it(I haven’t been on studio in like 6 months due to no internet) and I went and played around for a little making idiotic dances and what not… but that’s besides the point…IK joints icon won’t even appear anymore, so there is that bug.

Clearing Key Frames a.k.a Reset

When you try to clear the animation or exit the editor the last Key Frame you were on doesn’t reset instead the avatar is stuck.

The Plugin Icon
To be honest this version of the Plug in seems really broken to begin with considering the editor’s move tools never stop reacting to the rig even after you exit the plugin.

THE END


#9

@KnockOfScripting can you identify the steps you took to get this to happen? I’m assuming by IK joints icon, you are referring to the button that says Apply IK in the top left section of the Animation Editor? If this happens to you again, can you please take a look at the rig in your studio explorer and see if any of the parts have missing Motor6D’s (this is usually the most common reason for why the Apply IK button doesn’t show up unexpectedly, that or there are multiple invalid Motor6D’s on the part). Missing Motor6D’s would also explain why your avatar becomes stuck.

Why the Motor6D’s are missing is a mystery, and definitely the result of a bug. I will start investigating, but if you are able to get any consistent repro steps, please let me know!


#10

Its been happening since last night as far as I’m aware, but yet I’m talking about the apply inverse kinematics. I have not checked to see if any motor 6’ds were missing. I was just animating and playing around with the plugin when I started experiencing the bugs. I was originally doing it the old fashion way moving every join to suite my needs. After I uploaded the animation I closed the animation editor and the rotation and move tool wouldn’t go away. and the rig was in an odd position.

such as this but this photo was taken directly after I reopened studio to see if there was a chance the rig would reset. Rig builder is not at all affected by this I think.

EDIT: just replicated the move tool glitch from the animation editor.

I also just looked at the Motor 6D’s in LowerTorso. Not sure if there are supposed to be a bunch of roots but all, if not most do not have a Part0
NoPart0

P.S Multiple parts were selected in the photo but I also went through them one at a time after selecting all the roots.

If anything else is needed from me and you can’t get a quick response from me on here message me on discord: KnockOfScripting#3411


#11

From your screenshot of the Motor6D with a missing Part0, it seems like this is the same problem as what was originally described in this post. Have to tried going to Workspace Properties and setting AutoJointsMode to LegacyImplicit?


#12

bugs are still happening. This time it has something to do with undo. The editor needs a proper undo button and not several buttons saying what to undo. It breaks the whole animation editor and sets the length from whatever its changed from back to 2.


#13

Hey @KnockOfScripting, can you describe what you mean by “several buttons saying what to undo”? As far as I am aware, there are only two ways to undo in the Animation Editor. Either the top option of the Edit Menu or pressing Ctrl + Z. Would you also be able to provide a screenshot, video, or steps to reproduce the undo bug you are experiencing?


#14

Unfortunately I am having the White Window issue with the missing IK button too. Changing the AutoJointsMode to Legacy hasn’t done anything for me.


#15

Change it to LegacyImplicit and restart studio, see if that fixes it.


#16

@greywolf_sif Are these bugs fixed? Due to this forcing of Explicit mode we can’t rely on the workaround of LegacyImplicit to fix these animation editor bugs temporarily.


#17

The fix for this on the animation editor side should be live. Please do not hesitate to let me know if there are any issues


#18

Welp… Another bug for you sire. This bug if awfully similar to the motor6d bug. Got an error output from the plug in.

Image from Gyazo
Image from Gyazo

This one was created playing around with Inverse Kinematics mode: Full Body

By the output I’m thinking that IK mode is deleting the motor6D’s from the model. I’m just about to considering leaving Inverse Kinematics alone in the animation editor more of just because it’s too slow and has too many bugs that get fixed leading to more bugs being created. I recommend everyone else animate the old fashion way as well. Luckily I still have my weld code to weld to a rig named dummy so I don’t have to type it out again.

UPDATE After the animation editor is closed this happened.
I know you will probably say that it’s the same. No it’s actually not the bug has evolved like a virus in plague inc. Image from Gyazo
As you can see the grid and the selection for right arm has stayed along with the Rotation and move hotkey guide.


#19

@greywolf_sif I had more to add sorry if I overwrote your edit for my comment but more just literally happened.


#20

Thanks for bringing this to my attention. I’ll have to investigate what’s going on here. IK mode does temporarily remove Motor6D’s (because they conflict with the physics constraints), but you should get them back as soon as you have finished manipulating.

EDIT: Additional question…were any of your parts locked (rather than pinned), while you were playing around with Full Body mode? There is a known issue with using IK mode while certain parts are locked that we are in the process of fixing.