Shadow Bleeding in Walls

Hello, I am trying to achieve lighting similar to the game rooms. I can’t seem to get no shadows. I’ve turned off global shadows, raised the brightness, changed lighting mode to compatibility. But I’m still getting slight shadows!

Here is my current lighting:

You can see in the corners of the image I uploaded below that there is still slight shadows, I cannot have this. I need completely flat blocks with no shadows.

I’ve searched everywhere for shadow bleeding and more but I can’t find anything to fix this. If anybody can help please do.

Turn off CastShadow in appearance in properties of each part.

Select the part casting the shadow, go into its properties and turn of cast shadow x

I already have in every single part in the map.

I think it may have something to do with your lighting then. Try messing around with Technology in the lighting properties.

Perhaps it isn’t a shadow problem then, is the room exposed to sunlight?

Yep, I’ve used future, but that’s too realistic with shadows. Shadowmap and Voxel both are extremely bright for what I’m doing. Compability is the only one working right now.

1 Like

That’s just ambient occlusion. You cannot disable that.


It’s a black sky.

more characters

Ah! I’d tell you to change the outdoor ambient to white but that doesn’t seem like the problem, I don’t think you can make that vanish if the room is completely blocked and it isn’t a shadow problem.


heres the room, but the thing is that this room will be connected by others rooms, so its not like its just open space, its all blocked in but light still bleeds through.

You must have a certain block thickness and perfect meshing of block objects to prevent a shadow leak. Also depends on which lighting engine you are using.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.